M3 instead of M4 for FRAME function?

First of all, thank you for the software. I am enjoying a trial version and very happy with it. I will definitely buy it.

I have made the machine myself and now exploring a new world =)
The firmware is GRBL v.1.1h
Lightburn is v.0.9.07

  • I have enabled laser mode for my machine ($32=1).
  • I have enabled the “Fire” button and set the power to 0.4% (laser dot appears on S=4, max S is 1000)

The issue is that when I shift-click the Frame button and the job is not large in size the laser dot doesn’t appear at all because of the low speed of the carriage. It appears only in the middle of long enough straight or curved lines.
Frame function works perfectly if I disable laser mode.

The question is: Is it possible to configure Lightburn to use M3 instead of M4 for Frame function? I believe it will fix the issue.

Thanks in advance.

It’s not possible for you to change that, but it’s a perfectly reasonable request and I can make that change for the next release.


Thank you.
It’ll be nice to have the Frame feature with the laser dot with laser mode enabled.

This is done for the next release.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.