mA Meter Reading Won’t Go Above 6mA

SOLVED: It turns out the switch on the side of the power supply was set for 220v… once I switched it to 115v the mA meter worked correctly!

I posted this in a FB group but thought I would ask here as well.

I think I have a power supply issue but wanted to check here first.

I have a mA meter installed on my black/red laser. I had an issue trying to cut through some .25” plywood so I started by checking my mirrors… yep, they’re crap. I tried cleaning them but nothing worked so new mirrors will arrive today.

While waiting on the new mirrors I thought I might want to benchmark what I have now, so I drew a bunch of short lines and assigned a different color for each. I then set each color to increase in power by 10% from 20 to 100.

I ran the test and watched the mA meter… despite the increased power with each line, the meter never went above 8mA. However, it does look like the power is increased each time (see photo). Maybe my mA meter sucks?

Wire connections on the laser tube are good. Am on on the right track troubleshooting this? Any suggestions?


Check out the makerforum. You’ll find a lot of great information there and help of course!
It is home of the old G+ k40 group.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.