Macbook doesn't recognize my ruida machine

Hi, my macbook won’t recognize my machine. Adding it manually doesn’t help also, it doesn’t respond on any commands.

I’ve tried difference versions of lightburn, the problem still exist.

On this forum this problem is mentioned before, in those topics there is a link to different FTDI-drivers, this looks like my problem also. Tried it multiple times but this solution looks to old. There’s always one terminal-command that doesn’t work. Perhaps caused by my newer version of macOS. My laser cutter doesn’t have a ethernet-port.

Can someone please help me out?

Regards,

Erwin


Jeff, Thanks for your reply.

Unfortunately my machine doesn’t have an ethernet-port, so that’s a no go. In the linked topic, they did the same as I did, also many many times. His connection was achieved by rebooting, I’ve already rebooted my macbook during this proces at least 10 times.

Do you have other tips? I think the solution doesn’t work anymore for macOS 10.15.7, can anyone confirm that?

Additional testing is required to confirm Apple still has an issue with their virtual serial port driver. In the meantime, you have this as an option:

@Rick, it looks like his controller is what lacks Ethernet (not his Mac Book)

@erwinM, which Ruida controller do you have (that is without Ethernet)?

Apparently reading and comprehending is still a challenge for me today. Sorry folks. More coffee required. :wink:

No worries Rick! Hope your coffee waked you up.

In my laser cutter there is an DSP Ruida with build in computer.

Try this link - this is a more recent solution: Trouble getting 410C / Topwisdom to find my mac... NOOB

One of the best movies ever made :smiley:

trying to install the FTDIdriver again, it gives me this error:

And in the linked topic they say look into /dev/ where can I find this dir?

Are you trying to install this one?

That folder is likely hidden from you when viewing normally or through the finder. If you drop to a terminal window and cd /dev/ that might work. (I don’t actually know where that is in the MacOS UI - you can probably find it there too, but with hoops to jump through)

Didn’t try this one untill now. My problem is the same. The solution doesn’t work for me. I don’t have a notification where I can allow the driver to load. Is the system overview it says that the driver is to old…

have you tried allowing software from non apple approved providers? I have this off for a number of programmes i run on Mac OS and early Betas im testing/ working with, so forgot to include this step. Maybe try this and try again. The DMG should load and run automatically. What mac and OS are you using?

also i just followed the link and it was wrong are you installing FTDI (2.4.2). It should be FTDI (2.4.4) this is the 64bit driver. be sure to use this one.

Let me know how you get on.

How do I allow using software from non apple approved providers? I don’t get the notification in Security & Privacy to allow this software.

I’m using a macbook pro 2015, macOS 10.15.7.

My systeminfo says that the provider is known, but it’s to old. Installed version is 2.4.4.

10.15+ might be the issue - is that Catalina? It seems like they’re breaking compatibility with older software, and we’re getting pulled in two directions. We have a decent number of MacOS users on 10.11 and 10.12, and if we move our framework version forward enough to fix issues with 10.15 it’ll drop 10.11 and 10.12 support. MacOS is only 15% of our total users - we might have to drop support for 10.12 and earlier so we can support 10.15 and up, but this is a crappy position to be in - someone is going to be unhappy.

That’s indeed a crappy position to be in. For us, macusers, there’s no alternative to connect with our machines, that’s also a crappy position to be in :wink:.
The moment when you can’t avoid it anymore, comes closer each month. If I was you (works out for me also :slight_smile: ), I would support the newer versions. You can ask people to update their system, it’s difficult to ask them to downgrade. I would also build a warning in the update-message, so that people know what their doing. If they don’t read wel, they can always pickup an older version of the software.
In my case, it seems like I can’t do anything to get it to work…

OZ
I am running Catalina 10.15.7 on an iMac with my Nova Thunder 24 and all seems good.I have been paying close attention to all the Mac comments(problems) over the last 12 months and it seems most if not all of them relate to MacBooks and their connectivity. Maybe the problem is with the software framework of the OS in the MacBook then again I don’t know anything about Topwisdom or if any iMac people use them.
I just wanted to say one of the reasons I bought my Thunder Nova 24 was because I found Lightburn and it would run on my IMac and for that I am thankful .
Nev

You would be discarding a decent number of customers who have older machines that are being told the newer OS versions are not compatible with their hardware. I get an earful over the lack of Vista and XP support every so often too, but we have to draw a line somewhere.

We get a huge volume of emails asking, “when will the cameras be here”, and “when will I receive my new key?” when we have very large, bright red text on our website explaining both of these things on the relevant pages. I can state with certainty that a lot of people don’t read anything. :slight_smile:

You’ve said you have a Ruida - why not just get the $30 Ethernet adapter and run a network cable to the machine? Then there is no driver issue.

And it continues… :wink: