MacBookPro cannot find laser device consitantly

I have a FoxAlien Reizer 20W laser. My Mac is running Montery 12.0.1. I am using LightBurn 1.0.04.

I have been spending more time trying to connect to my laser than creating projects :-). I am wondering if anyone has an issue from the Mac trying to connect directly to the controller USB port from the Mac. Sometimes it can see the laser and I go thru all the setup and then when I download a project, it acts as if the laser is not there. Just as a data point, I have tried setting up a Raspberry Pi with Virtual Here and the Pi see’s the laser and my Mac thru the Virtual Here see’s the USB/Serial port, but LightBurn will not connect. When directly connected via USB, and it does find a device, it is usually GRBL-LPC, but sometimes it finds iLaser, but mostly GRBL-LPC. I sometimes can get it to reconnect by trail and error of unplugging the USB or unplugging the controller. Nothing repeatable at this point. Any advise will be appreciated. Thanks in advance. Dave

Did you ever figure this out? I can’t get this to connect for the life of me. Thanks!

Unfortunately I did not. The only thing that worked was repeated attempts. I did find if I went through the process of adding devices by running the scan several times, I could bounce back and forth between the various selections and sometimes it would pick it up. I eventually just bought the FoxAlien Offline controller. I just save the GCode file from the Mac and use it that way. Since I always hated having to take my Mac out to the garage when working on the Laser, it was something I had always planned to do. Wish I could have solved it, I miss not being able to do some testing etc. with the Mac directly connected.

I, searched the net and found no-one with a solution. let me know if you happen to find one.

My initial Mac connection problems were solved by adjusting the baud rate to 115,200. Occasionally I still have connection problems that are resolved by unplugging the USP cable then reconnecting it.

Thanks. I tried looking for places where I could adjust the baud rate but so far have not found it. Do you have any hints to share? I have a Mac Book Pro with two Thunderbolt 3 ports. I use a USB-C to the old USB adapter to get to the Laser controller.


Check Edit->Device Settings. Baud rate and transfer mode are selected there.

Look at the wrench icon in LightBurn. On the lower right side is an item labeled “ Baud Rate.” I reacted to online comments and lowered this to 115,200. Thereafter, I was generally able to connect with my Mac Mini.

I am on version 1.0.06 of Lightburn. I do not see anything displayed on the the wrench icon page.

Thank you. not sure what I am doing wrong, but I will keep picking at it!

It’s possible that’s not available on Mac.

This is what I was referring to:

David, you are looking at the wrong dialog box. It shows on the wench icon and not the gear icon.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.