Machine homing after macro

I’m trying to align my mirrors on my custom built machine (controller is a Cohesion3D LaserBoard). I have the following macro that I run to give a 1 second burst from the laser:


But after I’ve run it once, when I go to run it again the machine wants to home first, which is in the opposite corner. Homing works just fine, I just don’t want the machine to do it at random times. :smiley: I’ve noticed the issue before but never noticed a pattern. This time I’m running the same macro repeatedly and getting homing on each subsequent run of the macro.

Here’s an example from the console:

Starting stream
Stream completed in 0:00
Starting stream
Stream completed in 0:00
Starting stream
Stream completed in 0:00

I click the macro button and it streams something, then homes and I have to issue the macro again, which works fine.

OK, now it’s homing before anything I do, even trying to jog. Never used to do it all the time, but occasionally would. Something has changed and I can’t figure out what it might be. I’ve been doing incremental testing as I build the machine. Got the X-axis working first, then the Y and the limit switches. Had it homing and moving just fine. Doing everything it should when it should. Then I notice the extra homing it was doing and thought it might be homing after extended periods of time or after the computer woke after going to sleep, but couldn’t nail it down. Now I’m at the point where I have everything connected so I can test and align the laser and it’s homing before each command.

LightBurn does not randomly send homing commands to the board, but there’s one reason that it will happen: USB disconnect. If you brown out the board and it powers down, then back up, even for a moment, the loss of connection and re-establishment of it will trigger the “home on startup” sequence, which is most likely what you’re seeing.

Since this seems to happen when firing the laser, you may have a grounding issue, ground loop, or power noise issue.

I am getting something similar, but different.

There are times when I hit the start button and the laser will move for a fraction of a second towards the start of the cut, then it will say “Finished” on the “Laser” tab, and home the gantry. This not the “Finish position” that I set. This ONLY happens in the cut command, not when I scan (or fill, I know there are new names for these functions), and it is very intermittent. But I have never had it happen twice in a row.
Once it has finished homing, I hit start again and it works as normal. I know if the program runs for a complete second, it will go through the whole program.
I have the latest update (not sure the number, I am at work and cannot check)
I was waiting to see if DaveAK was having the same issue, but it seems not.

Any thoughts?

TS-6090 80w
cohesion 3D

It doesn’t? Maybe I should suggest this as a feature for a future update! :smiley:

Anyway, I think you’ve identified the problem which is what I was after. So thank you! Now I just have to figure out a remedy. :thinking:

So I stripped everything down (electrically) and started building and testing from scratch. Seemed like the chiller was the culprit. When it kicked in I got the disconnect. Put it on a different outlet and no issue, until I hooked up the laser and did a fire. So my guess is it’s electrical load in general, or a combination of the load and interference when the laser fires. Either way I’ll work on both areas tomorrow and get it fixed now that I know what I’m looking for. Thanks again for pointing me in the right direction!

So my guess is it’s electrical load in general, or a combination of the load and interference when the laser fires.

It could also be a ground loop.

Yes, considering a ground loop too. But I don’t know exactly what one is or how to remedy it. Gonna hit up Google tomorrow. :thinking:

@bcer960 - Likely the same issue as Dave is having. If it’s homing, it’s the board resetting, and that’s almost always an electrical noise issue if it’s happening instantly or when firing. If it was happening in the middle of a really long run I’d suggest an issue with the USB port going to sleep. It could be the physical port connection too - sometimes they wiggle, and a little noise can be enough.

Google is your friend, but this also came up recently: Ground Loop

Ok, I’ll try plugging the laptop into a different plug, on a different breaker and see what happens.

Yesterday I was using the machine for many hours using the fill operation. Had no issues at all. I then wanted to cut a circle around one piece. I added into the list operation, in between 2 fill operations, and when it started to cut, after a millisecond, it stopped, and went to the home position.
So, it is only happening when I cut. But not every time… seems weird it would be this way if it was a ground loop

Ray, I should have circled back after this. My issue was definitely USB related. I originally thought ground loop as I had some suspect wiring. I changed this and still had issues. Eventually discovered that the USB cable was faulty - it had got damaged along the way. I got a new longer cable and routed it away from the HV stuff, but put my wiring back as it was - including a potential ground loop. Problem solved.

Another consequence of the dropped USB connection was that during a cutting operation it would fill the buffer before firing the laser, then when the laser fired it would disconnect but complete what was in the buffer. On a square it would look like it was completing the job, but on circles it would do exactly the same arc length each time before stopping. So depending when the USB drops determines how much data is in the buffer and what gets cut.

Don’t know how much of this will help you, but my issue was definitely USB related - whether ground loop, cable routing or cable damage or a combination I’m still not entirely sure.

Thanks DaveAK,

Mine is definitely something different as it only happens on a cut, not a fill. but not every cut. Happened again today.

I’ll keep working through it.

Are you running the cut with a higher power setting than the fill?

If it started to do the cut, then stopped and went home, that implies that the board browned out (lost power momentarily) and reset.

yes, I was doing the fill at 40% and the cut at 80%.

So, this might be a power supply issue?

Power supply to the board itself - If you have everything plugged into the same power strip (including blower, air assist, laser, etc) you might be pulling too much juice when the laser fires and causing a brownout. How are you powering the controller? Separate power supply, or … ?

Yes, it is on the same power supply, and yes, it is a cheap(er) Chinese laser. I will get a new power supply just for the control board, and see if that works.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.