Machine randomly slowing down during image engraving

Hello, I have troubles engraving images with an xtool D1 pro.
The laser will stop/slow down suddenly almost like it’s hitting something and then resume work.
The work can be completed but it takes much longer than it should and I have a feeling it might not be good for the machine either.
As the problem is difficult to put into words I took a video: problem laser
Every “clank” heard is the laser head coming to a brief stop and restarting afterwards.

A bit more details:

  • Problem does not occur on every image, it does not even occur continuously on problematic images, only on parts. Seems to occur on parts with a lot of black but I’m not sure.
  • Problem goes away when reducing the speed by a lot and depends on the image engrave method. ex. Problem will appear at 75-100mm/s for grayscale but only from 150-200mm/s for Jarvis.
  • Problem does not occur when using xtool XCS software, only with Lightburn.
  • I’m suspecting this has to do with speed of data upload to the machine (Jarvis probably less data heavy than grayscale hence the higher speed before the problem occurs?) but I might be completely wrong… I tried with various USB cables but it does not change anything.

If anyone has any hindsight on this thank you very much.

you may have the dot width correction turned on, turn it off in the settings.

groet Sjaak

Thank you for your reply, I checked and sadly the problem occurs even with the dot width correction turned off.

Are you willing to share a capture of the preview window or perhaps your LightBurn file?

The laser has a maximum traverse speed and an engrave speed. There is an acceleration or deceleration between these two speeds. The head of the laser shouldn’t stop while engraving but it should go as slow as the slowest speed. If the engrave speed, matches the traverse speed the acceleration is never applied.

If it’s a data rate problem as you propose changing the DTR setting may help:

As an aside - Clustering should be off. (I don’t think this is the issue at hand. There is a remote chance it’s this and may be present because of the observed performance difference between grayscale and Jarvis.)

Another strange occurrence with other devices is the microcontroller (Espressiv) mounting itself into Windows as a hard drive. Please open the control panel, expand the drives section and check for the Espressi Mass Storage drive shown in the Ortur LM3 thread.

The xTool uses the Expressiv controller chip, so it may be subject to the same unusual hard drive shenanigans.

Thank you for your support.
I tried with and without DTR and the problem remains the same. I suspected data rate because of the difference between grayscale and jarvis but it’s just a guess, it might be something completely unrelated.
Clustering is off as you guessed. Here is a screenshot of the settings just in case.
I also tried with and without whitespace scanning but it did’t change anything…

Link to a file where problem occurs: Dropbox - Lightburn - Simplify your life