Major BUG in 0.9.23

Thanks for taking the time to reply to this. I know that software development is very complex and dealing with users even more so.
However, our frustration as users is somewhat justified because we are paying for the software and the expectation is that it should always work. When it doesn’t, we turn to the only place provided for support and the first few responses we get turn the blame on us for not doing our due diligence when upgrading or not reading the forums. That does not feel right.
This software is amazing and it seems like the dev team as well. Some forum moderation would not hurt as well as improved user communication from your team and as you mentioned, a more robust testing workflow.

Absolutely agreed. We’re in the process of expanding the team some, because I’m lead dev and also the owner, and a decent number of support inquiries still land with me (see “lead dev”), so I end up being spread thinner than I’d like. We’re also in the process of moving, and recently had a couple of our support folks out temporarily, and all of this happened around the same time, so it took longer than usual to clean up.

All of our releases have an issue here or there, and that’s mostly normal with software development, especially given the number of system configs supported by LightBurn - it’s hard to test all possible combinations - but we do test, we have beta users given early drops during development, and we try to fix issues quickly when they do come up.

This one was different though, so I’m trying to make sure it doesn’t happen again, once we get this sorted out properly for everyone affected.


Testing across all of the controllers and OS versions is a nightmare. Especially Macs with external HW. Reading the posts about testing across all of the Macs and OS versions brought back some similar nightmares I had in the past. That was the key reason I stopped doing SW on the PC/Mac environment. The FW/SW Version/HW Version testing matrix just got to large and I didn’t have the skills to tackle it even though the money was good. Good luck on getting your test infrastructure up and going.

1 Like

I work in industrial IT supporting business across a dozen or so industries that use a variety of proprietary industry-specific software. To be blunt I’ve rarely seen the level of support that Lightburn offers directly from the devs for free. Typically, there is a monthly fee for this level of support, especially for ‘one-and-done’ purchase software that doesn’t already include a recurring monthly cost.

I’m glad to hear that rolling back to a previous release resolved your issue. As others have mentioned their best practices, one of my favorites is to keep the installer for the versions that have worked for you in the past backed up someplace safe. Since Lightburn makes the repositories of past builds publicly available it isn’t as crucial here, but a lot of companies purposely do not make their older builds available which can be a real headache. This tends to be especially true for drivers.


I have been having major issues with 9.23 crashing repeatedly. I did a suggested update and it seemed to fix it, but then a couple days later its crashing again while doing something different. First time it crashed repeatedly it was while adjusting nodes on a design I was doing. A simple flag design. It would crash, I would have to start over. Then I started saving progress, but I got to the point that I had to save every 45 to 60 seconds because I knew it was going to continue crashing every couple minutes. Then I did an update that came up on the program, and it seemed fine for the last few days. Now today, while using the pencil to trace some parts of an image, it has crashed again. Should I just go back to .9.22 or .9.21? My computer is running windows 10 and hadnt had lightburn crashing issues till the newest update…

This is not good. LightBurn should not crash, so thank you for reporting this. Do you get any crash report or message displayed when the crash happens? There is information in that message that tells us what was going on as the crash happens, so we would like to see any that get presented.

You can roll back to a ‘known working for you’ versions from this link: Older Versions of LightBurn.

Additionally, we are testing a version that addresses some communications issues we have with the last public release. If you are willing, we have an update version for testing you could try.

Are you getting crash dumps and sending them?

Exactly the same issue here. Ruida 6442 and lightburn 0.9.23 cannot send any files from a Mac.
The computer does connect to the Laser via USB and commands such as option-L are being received and executed. We have rolled back to a previous version in order not to disrupt operations.

Then we can move to,

Hi sorry for the late reply. I took some screen shots of the first time it was crashing last week when it crashed multiple times. I only have a couple of the errors it made in pics. I didnt take pics today because honestly I was pretty frustrated when it happened. Hetes what I have tho. The pic with the red line literally goes off into infinity and popped up the message shown. When this happened I was editing nodes and doing offsets on the design. I had never seen that message before or since, but I cleared the message, went back to editing nodes and then it completely crashed and sent me the lightburn has crashed popup.

I haven’t had any serious communication errors when sending files to either of my lasers as of yet. If I have , my thoughts so far was that was user error.

Yes, thank you. We need to see these when this happens. LightBurn should not crash, but it can happen, and we need to know, or we won’t know what need to be addressed to provide the most stable software possible. We try to tell you this in that message where it says, “LightBurn has crashed. Send a screenshot of this message…”, and so on.

The development team can now review and provide some feedback. Thank you for providing this report.

I knew I had a design with a few nodes since I’d done lots of editing when I created it weeks ago so I thought I’d load it up in 0.9.24 and 0.9.23, edit some nodes and then try the offset feature. Seemed to handle it ok so far. Linux KUbuntu 18.04 16GB RAM and NVidia graphics card.

@Custommade , that star is very light on nodes though and it doesn’t look like you’re editing nodes when doing the offset. With some help explaining what process you do to cause the crash it’d help in reproducing the problem.

During the multiple crashes of the flag design, it happened while editing the nodes of the stripes on an American flag . They were simple rectangles for each stripe and I used the nodes to remove the overhanging ends and join them to to the offset lines that I had created around the original line drawing. I can pull up the file and show several stages of the design if needed. This was why I had to save the design every 60 seconds before it would crash again and I would lose progress.
The crash that happened today that I did not take pictures of (but if it crashes on that design tomorrow I will for sure) happened when I had an image open and I was using the pencil to go around the image and drop lines and nodes that I would be able to tweak afterward. The image had poor contrast that I wasnt able to use the trace feature very well on it, but I have had success with tracing difficult parts such as this with the pencil tool before. I can take some pics of the design tomorrow morning and show you what I was working on. I was literally tracing an outline of the continents on a globe map with the pencil tool. Very simple stuff. Partway thru the design it popped up amd said lightburn has crashed and it shuts the program down. I reopened the program, selected the file from the dropdown menu for recent files and opened it. It had not saved any of the mornings progress on the file. Thats when I gave up on it and worked on other things until we can figure out what the solution may be. Thank you by the way to everyone helping with this!

Something is nagging at me that this problem is related to an OS update. v0.9.23 is the latest version of LightBurn so there would not be a suggesting from the LightBurn software for an update. What did you update?

Here again you state that LightBurn indicated you needed to update by you stated you already did and were at the latest version. Seems something other than LightBurn is telling you to update and it should seem strange installing the same file( LightBurn 0.9.23 installation ) over and over.

Maybe it’s graphics drivers in Windows 10 and not LightBurn?

v0.9.23 is the latest version of LightBurn so there would not be a suggesting from the LightBurn software for an update.

We did a critical patch because it was possible for node editing + undoing all changes to cause a crash, because of the way the geometry sharing system was handling things. The update to 0.9.23 fixed this issue alone.

I found it strange also that there was a suggested update of .23 after I had installed already. I thought perhaps it was an update on some of the issues that had been going on, so i went ahead and clicked on it and updated it, followed the install and finished it out. Are you suggesting the windows 10 graphics driver is making lightburn crash? Wouldnt it have a popup for that , saying something had gone wrong etc? Something similar to the lightburn crash popup? What was determined from the popup in the picture when it crashed before? Sorry, if its alot of questions at once

I see you posted there was an update to .9.23 that was a patch to fix crashing during node editing. Am I correct to assume that this patch update was the prompt I received for an update after I had .9.23 installed? Please correct me if I am misunderstanding.

Yes, this is the sequence you experienced.

We released 9.23 April 07, 2021. Then patched that release, 2 days later on April 09, 2021.

1 Like

Ok. Well, this just happened. It had 2 pop ups when it crashed, I was only able to take a pic of the one notice. I took the pic, hit ok, and it shut down before I could take the pic of the second popup. I took 2 pics so you could hopefully see a little of what I was doing in the background. 0421211352|666x500