Makerbase DLC V2.0 GRBL 1.1h

Good day,

I’ve updated to GRBL 1.1h on my Makerbase DLC V2.0
But now when I connect the usb it sounds like the stepper motors turns off, when I unplug the usb I can hear them singing like always, very strange. I’ll send a screenshot of my console later, maybe someone had the same experience.

How do you know this is not normal? What is the value for the $1 parameter?

When you “upgraded”, that means you flashed new software into the controller board, right? That means all your GRBL parameters may default to something other than what is correct for your machine. You did save a copy of the old parameters, right?

1 Like

Hi MikeyH,

I don’t think this is normal as it has not done this before. $1=255

Yes I flashed to 1.1h, unfortunately I did not backup before flashing (rookie mistake), but I do load the presets from openbuilds control software for my machine.

This means you lock the steppers while the board is idle. The console output is also fine. I don’t spot any issue here. The laser should work fine.

1 Like

Offering a guess here, but I suspect the steppers are hunting for position (dithering) when the controller is powered up but not under any control (free running). Likely it is a quirk of the GRBL software version you installed. Silent is what you are supposed to get when no motion is commanded.

Problem found.
Was on $4=1 changed to $4=0 all good now. Thank you for the suggestions, much appreciated.

$4 - Step enable invert, boolean
By default, the stepper enable pin is high to disable and low to enable. If your setup needs the opposite, just invert the stepper enable pin by typing $4=1. Disable with $4=0. (May need a power cycle to load the change.)

2 Likes