Minor bug/improvement opportunity

I noticed an unneccessary movement waste. I’ll try to explain:

I have a ring, with some holes in it along the rim, and some decorations in the middle. It then cuts like this:

  • Decorations in the middle and holes. This is OK.

  • Outer edge. This is the correct order, but it finishes the holes with the “3 o’clock” hole, and then starts cutting the ring at the “6 o’clock” position, instead of just making a tiny jump and cut at “3 o’clock”.

I assume that this is because the shapes, even if closed, have a starting coordinate, which will be used as a starting point. Basically, the first coordinate in the list that makes the object.

If it was able to hop in at any point of the perimeter, some unnecessary traversal moves would be eliminated.

Note: I have no idea about the practical effect of this. In my case, it was an unnecessary move of maybe 300 mm, so maybe a second lost. No biggie, and I suspect that, except for a few special cases, the effect will be minimal.

No biggie, I’d just thought I’d mention it.


Have you done a test with optimization cut checked / unchecked (in the Laser window)?

[X] Optimize the cutting path

And also change some options in the Optimization settings’ button ?


I’ll check. I usually have every optimization checked, but I might have missed one, or it might have been lost in the update.

This probably has no connection, but according to the tutorials I keep reading, if I understood correctly, if a part contains other nested parts, then the software starts by cutting the internal parts and then the external ones, so that the whole thing doesn’t fall after the first cuts if it is on a support (I suppose?)
This can lead to movements that may seem strange to us humans.
It reminds me of the first time I saw a tracing table (almost 30 years ago) that to draw two circles side by side, draw the first half, then circle 2 and then come back and draw the other half circle from the first and that makes sense.
It’s quite fascinating to follow.


There are several options for you to explore to refine you cut order. Marc is correct for suggesting you look at the options you have set under the ‘Optimization Setting’.

Simply turning them all on is not the best as some of these options can change behavior in ways that you might not expect, E.g. setting a shape cut start point and then selecting ‘Choose best starting point’ in optimization could alter expected results.

You can learn more about optimization and the cut planner here: