Misalignment issue - help!


(Julia Quinto) #1

Hello!

This is my first real project, so imagine my excitment plus frustration! So I’m trying to produce multiple keychains for school where I work. I designed a little in Illustrator, and most on the LB platform. I’m cutting with an Emblaser 2.

When I cut one, it turns out perfect. Two, it was great. Then I copied and pasted the design to cut 24, the bottom row cut fine, but it started misaligning from second all the way up. I thought I had too many on the page, so I just did 2 by 4. The bottom row again looked great, but as soon as it traveled up to the 2nd row, it was being funky again. Did I do something wrong? I was wondering if zigzaging each item might have caused it, but why? Thank you!


(Rick James) #2

How does this look in the ‘Preview’ window? What version of LightBurn?


(Julia Quinto) #3

I tried uploading both pictures, but only let me upload one, since I’m a newb. lol!

LB says I’m up to date on updates. :woman_shrugging:t2:


(Ray Kholodovsky) #4

Try uploading again.


(Julia Quinto) #5

So this was my second attempt. I thought maybe there was an upload issue. The first print was of 24, were the bottom 6 were good and the rest misaligned. I just found my 1 vertical colume of 4 all messed up (I think another reason) so I’m attempting a 1 row of 5. Checked my preview, saved, and then uploaded. Could it be a Emblaser issue?


(Oz) #6

Check to make sure that all the belts, bearings, and rails are clear of debris. When you preview, what does it look like? (small TV monitor button, or Alt-P) If there are issues with the cut data the preview will show it. If the issue is mechanical, the preview will look fine.


(Julia Quinto) #7

The preview shows exactly what is in the design space. If the problem is mechanical, will it still make the first one and the bottom row the way it should while the rest is consistently misaligned?


(Oz) #8

Possibly - depending on the order they are cut in. Mechanical issues, like belt slip or steppers missing steps, can happen, and when they do they generally affect everything that comes after. So if the outline that’s off is the 2nd thing cut, and then everything after is aligned again, that’s probably not mechanical, but if all the scans and first few outlines cut properly, and then it slips, and everything after that is off, it could be mechanical, yes.

Try shifting the entire job a centimeter to the right on the bed and see if it still happens. Sometimes a rough spot or dirt on a rail is positional.


(Julia Quinto) #9

Refering to a cut I just tried a little while ago, when I came out to check, the board had moved. What the heck caused that? Same type of mechanical error? Wrong topic and forum probably, but what is the best way or tool to clean the railings, etc? I don’t want to mess anything up! I will check to see if everything is clean tomorrow, try to do a vertical column and see where everything ends up!


(Oz) #11

The machine in question is an Emblaser 2, and they use two linked motors in a CoreXY configuration, so if a single motor is bad, things move diagonally, not horizontally or vertically. It is possible for debris on the linear rails to be an issue, but the belts aren’t usually a problem - the E2 doesn’t move aggressively enough to cause belt stretch like a CO2 machine would. It’s not a machine that usually requires this kind of maintenance.


(Oz) #12

I would check with Darkly Labs - they have great customer support and might be able to help you troubleshoot this better.


(Julia Quinto) #13

Thank you. So you’re sure it’s most likely mechanical error rather than something with LB, right? I just want to make sure, as I keep going back and forth. My “test” projects with personal photos, the spirograph, all seemed to go ok (aside from playing with power, speed, etc). Then when I had tried this particular project, the second layer and up seems to misalign repeatedly. Thank you again!


(Julia Quinto) #14

Just one more question:
I worked on a project just before these little keychains. It was a larger image with words on the bottom. That engraving did not give me any issues. I’m trying to wrap my mind around why it would start cutting at an off spot for this project when I moved the designs a bit and cleaned the railings (unless I’m not cleaning it well enough). I will take my question over to darkly labs, but I just wanted to see if anyone had thoughts on this. Thank you!


(Julia Quinto) #15

So it may still be a physical mechanical issue, as I’m still trying to troubleshoot the misalignment from 2nd row up, but I’m thinking it also could be not…

  1. When I engraved a picture taller than the project in question, it engraved without skipping a step.

  2. I took the same design and uploaded from a different laptop, the same issue occured, but this time, from the bottom row after the very first cut. Meaning, only the cut nearest the origin was as it should and the rest were all funky, which was not the same exact misalignment as the pictures above.

Could the error be in the actual file? What do you think?


(Oz) #16

There’s a simple way to check: use “Save GCode”, save it as a txt file, then copy that text into an online GCode simulator and look at the result.

I regularly use this one to spot check for issues: https://nraynaud.github.io/webgcode/


(Julia Quinto) #17

Hooray! I think this issue has been solved! Darkly lab helped me locate the problem. The speed was set too high, causing the motor to slip and lose track. I tried this at a lower speed and the issue seems to be resolved.

I am not sure how to save as GCode as txt file, but I will explore to look into this.
Thank you for your help everyone!


(Ray Kholodovsky) closed #18

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.