Modified K40 Abruptly Not Working

Sorry to be that guy, signing up to post a help question… but here goes-

A little backstory and context-
I’ve had this k40 since about late 2019 early 2020. Using k40 whisper (which I didn’t like) I used it a little and it sat a while outside of random projects.

The last two years though, it’s been a workhorse. I’ve gone through a couple power supplies, and rewired this thing a few times. The last power supply issue was basically water damaged. The tube cracked during a random hard freeze (out of sight, out of mind) and the water got to the power supply. When I noticed I opted to just install a new one rather than blasting myself with 24v. While waiting for the replacement parts, a friend of mine asked for some help with his laser and some parts, which I went up and found this giant Thunder Laser. Long story short, was introduced to Lightburn and enjoyed how much more useful it was than Whisperer. Ordered my own Omtech board so I could get my own copy of lightburn that night.

Outside of that I do have a fair bit of experience with other similar-in-concept machines ranging from hot rodding 3d printers to Haas CNCs, to building my own Langmuir MR1 CNC Mill and have had some time running a LaserStar fiber laser.

Anyways, since, I’ve been running the laser with lightburn for at least a couple times a week for well over 1.5 years now probably. I use it mostly to cut leather parts and these acrylic lens things I constantly need.

Now, a few days ago I was running the laser at night, cut my parts. When finished, I shut the laser down and turned off my laptop like I’d done 1000 times.

The next afternoon, usual start up process to cut more parts, and the laser won’t work.

The USB is recognized and makes the chime sound, Lightburn appears to recognize the device, and the smoothie board is even shown in my control panel hardware list.

However, it doesn’t seem to actually recognize the device, if that makes sense. It appears to connect, but will not home and even if I run a program that normally lasts 7.5 minutes, it’ll flash and say “completed 0:00” with no movement or physical response from the laser.

At the recommendation of these googled forum posts and Lightburn customer support— I’ve tried a new USB cable, manually selecting the com port, I’ve reinstalled lightburn, I’ve cleared my ports, I’ve power cycled in every imaginable combination, manually selected my com port, and even ordered a new OmTech board, and other stuff I’m probably forgetting… all with the same results. I even just did a windows restore and fresh, up to date copy of lightburn. Nothing. I’ve double checked all wiring and connections, the laser still fires by way of the test switch, so I don’t think it is related to the PSU.
Edit- I also tried new SD cards in the OmTech board in case it had corrupted or something.

My LightBurn on the fresh installs did recognize my board.
As stated a program that normally would take a few minutes, streams and completes in 0:00

Attached are quick photos from my console showing the aforementioned points.


Again; I’m sorry to be that guy to join and post for help, I’m just at my wits end. Not to overshare, I’m a disabled veteran and this cheap laser does so much to contribute towards my business’s end product and does much more in terms of helping me not go insane from boredom. I just don’t understand what changed in a matter of a couple hours of the laser just sitting to cause whatever to go wrong.

All things considered it feels like there’s some setting I’m overlooking that I may of fat-fingered when closing up the shop that is effectively locking me from operations.

I do have a MacBook I’m trying to see if it’ll work with, but my daughter has ‘misplaced’ it’s charger :smiling_face_with_tear:

Edit- apologies also if this is not the correct section. I asked in the software section due to how it seems like I’m locked out

Edit 2- to test the steppers and hardware side, j just swapped my factory K40 whisper board in. It works with that.

When it boots, does the mechanical parts move so it can complete a home operation?

From what I can pick out it does this… confirm?

Is this the OMTech board that’s grbl?

Does Lightburn Laser window show the device as ready?

The output looks like it’s working, but can’t see what the machine is doing.

Can you jog it via Lightburn?

:smile_cat:

Thank you for your service. Sorry to see the “D” in front of Veteran.

Does this mean the laser moves per the program after downloading to the controller?

Thanks for the response-

To clarify, no movement. No home on connect, no manual jog, no movement at all… unless I move the gantry with my hand.

In that context I meant “laser” as in the entire unit. I realize I could of worded it better here :sweat_smile:

Easiest way to say it, the machine does nothing at all on connect or command

It’s like my PC recognizes the laser and faux-connects. But I effectively have no use from tang connectivity.

The board is the OmTech K40 plus
OMTech K40+ Laser Engraver… https://www.amazon.com/dp/B09MD249K7?ref=ppx_pop_mob_ap_share

No worries, I appreciate it. I have 0 regrets!

Correct. I hot swapped the k40 factory board in there to diagnose any hardware issues or shorts within the unit itself. When loading a .dxf file; k40 whisperer runs the unit as it should.

Which further makes me feel like there’s some software side thing I’m overlooking that’s boogering use

So you swapped hardware and it worked but think it is a software issue?

Not sure how yours is wired up, but my CNC 3018 powers the controller board via USB and powers the steppers thru the controller board with a 24v supply. In other words, the board could talk even with no power to the motors. It sounds like that is your situation with the Smoothie board.

By the way, keep answering Jack’s questions too. He has a LOT more experience with these lasers than I have.

Yes. I think it’s a software thing.

1- lightburn stopped operating the hardware, overnight. I have two identical OmTech boards, with both producing the exact same issue. One board is brand new, both SD cards have the correct firmware and proven config files. The likelihood of my board failing and having a brand new board produce the same type of failure seems low.

2- replacing the OmTech board with the factory K40 board, and using Whisperer instead of Lightburn confirms that the hardware* is not the issue in my opinion. I swapped back to the factory board in order to troubleshoot wiring, steppers, PSU, etc (*edit 2- excluding the main board, but again… both Omtech boards?)

I’m not trying to be quippy, I appreciate the response. I’m just trying to be direct. But this laser has been a workhorse for quite some time, it’s not a matter of me forgetting to apply it’s main power.

Also, if it is a hardware problem when I attempt to run a program would the software show “0:00” for the total time when it should take ~10min? Or would lightburn just assume all is well, think it’s running for that time and the physical hardware just wouldn’t move? Again, not trying to be a smart Alec, I’m actually asking

Lightburn does not operate the hardware, only the controller board does that. Lightburn only sends messages to the controller and receives responses. With Show All checked, you can see those responses in the Console window. What Lightburn does next depends on those responses…

I did not know you uses Whisperer instead of Lightburn to test the K40board. That introduced another unknown into the test stream. Can you test the K40 with Lightburn?

We know that! You are seeing things differently than we are Just be careful to not make assumptions without testing. We are not being quippy either. We are ALL asking questions to help discover the root cause of your issue.

Yes, this can happen. This is a Request-Response system, just like web pages. Lightburn sends a request and waits for a response. If that response is “Ok”, Lightburn thinks it is.

With the OnTech board installed, using Lightburn with the Show All button button in the Console window checked:
Do not Home the machine, use Set Origin instead.
With a simple box or circle loaded, click the Run button.
Copy everything from top to bottom from the Console window and paste it in your reply.

And we go from there. And yes, it IS possible, but not likely, to have two OnTech boards with the same issue. Firmware is not always that firm.

The question was, when you power it up does it home.

It should do this without any external pc connected.

Your description is probably the result of a wiring error or a bad control board.

I understand that these boards are plug compatible with each other… This would point at the replacement controller failing.

Did you do any wiring changes? Since a swap back to the old control board works, all the supplies should be working.

A hot swap means it was powered up when you changed the boards out… is this what you did? Not a suggested operation.


If you did no changes to the supplied sd card, it should home when powered up with or without a connection to external software.

If it does not, then the board isn’t working.

I’ve gotten many new replacements in my life that the first couple were bad… in one instance I got a $3K cable, that took 4 of them to get one that worked… fortunately I didn’t have to pay for them.

Everything you spoken about indicates a failed controller board…

It should at least home on power up, it can’t be that broken if it’s software.

:smile_cat:

I believe we may be getting into semantics as far as what stuff is ‘called,’ I apologize for not using the correct terminology.

My thinking is that Lightburn may not operate the hardware, but effectively it does as there’s no way to control the OMtech board without lightburn. To me, sort of like—yeah my pedals in my car doesn’t operate the rotation of my wheels directly, but from an overall view it does…

The end state currently is with lightburn and omtech, the entire machine and everything within the enclosure does nothing. No home on power up. The only thing (if we can consider this doing something) is the LEDs on the control board do blink when connected.

I didn’t take any of you as being quippy. I just felt like without ever hearing from me or ‘knowing’ me, not ever seeing my way of expression or writing, I wanted to clarify that I am grateful for the replies, ideas to help, and wasn’t trying to be a smartas$ or anything.

I will get to the suggestions and post my console info once I get back to the unit.

Thank you

It does not home on power up. But to be fair, it’s never boned on power up. Won’t the omtech board it’s never homed until lightburn was open, connected and ready to run.

No wiring changes. Prior to trying the OEM board, there were absolutely 0 changes. It was running great for a long time regularly. Shut down one night, and we I came out the next night it was like this.

Apologies on hot-swap. I meant it in the sense of “changed on the spot.” It has been power cycled to test since the OEM board was put back in.

The boards being cheap and Chinese, I don’t doubt the possibility of two being bad, but identical failures after the one worked perfect for so long? I don’t doubt the possibility there but the chances even from China seem small.

For the firmware thing, is there a spot I can find the generic firmware and just revert back to that, to diagnose if something corrupted in the firmware or config files? I have had files randomly go bad on SD cards with 3D printers.

As mentioned in my other reply, once I’m back to the shop I’ll get my console copy and pasted in here

You already said Whisperer can control the machine, or is that one exclusively K40? And what about LaserGRBL?

That is another clue. It implies the board is communicating with the PC.

Mine is the same way. Lightburn sends the $H command to the controller. Some controllers Home on power up, even if not connected to the PC.

You need to know the software version for that manufacturer’s board. They sometimes customize the software to suit their particular requirements. A generic package might be okay, but no warranty.

I will be out too. Jack knows his stuff better than I know my stuff. Follow his lead if he makes suggestions.

I only own two small machines, so my view used to be very limited. I am stunned by the variety of machines out there, commercial and home brew. Design, sizes, controllers, firmware, and laser types is a mind boggling array of details. I realized this after reading most of the topics and postings here. Be patient for we will surely figure this out working together.

Below are is the console copy and paste–

Waiting for connection…

Smoothie

ok

Smoothie

ok

ok

Homing

ok

Starting stream

G00 G17 G40 G21 G54

G90

G0 X0 Y0

G91

M3

M106

G0 X0Y0

Layer C00

G1 X-9.833S0.2F6000

G1 X-9.834

G1 X-9.833

G1 X-9.833

G1 X-9.834

G1 X-9.833

G1 Y9

G1 Y9

G1 Y9

G1 Y9

G1 Y9

G1 X9.833

G1 X9.834

G1 X9.833

G1 X9.833

G1 X9.834

G1 X9.833

G1 Y-9

G1 Y-9

G1 Y-9

G1 Y-9

G1 Y-9

M107

G1 S0

M5

G90

G0 X0 Y0

M2

Stream completed in 0:00

The home command is the automatic one, I didn’t manually command that.
Its also worth noting maybe that both axis steppers are disabled. I’m able to freely move the gantry as if the steppers are disabled.

Whisperer will work if I use the factory board. Which I suppose is an okay iterim solution as I’m not totally dead in the water. But the Whisperer software and the factory board are so bare bones, it’s not nearly as user friendly or useful as the OmTech and LightBurn setup. Moot-costs aside, ideally i would much rather use LightBurn. The factory board and whisperer do not have multiple layer capabilities or the ability to control laser power so its a huge, convoluted pain to operate in my case.

I’ve never actually tried LaserGRBL to be honest. I do have a GRBL Controller app on my PC, but I kind of thought it was for my little desktop CNC Engraver

Due to my history with 3d Printing, I’ve made it a habit to keep backups of confirmed working firmware and config files. During my troubleshooting prior to posting here, I did revert back to those backup copies. So I know I shouldn’t assume, but I do assume they’re good. The factory reset firmware/config file bit was sort of “thinking out loud” on where to troubleshoot next.

I do appreciate the help.

Wait, what? @jkwilborn a $3000 cable!? Sounds like some controller cable from Haas!

I do have a diode laser I could hookup to the aforementioned little desktop unit. But Im not savvy enough on actual laser specifics to have messed with it yet, or to know if it would work for my usage.

I’m to the point I’m looking at just getting a slightly nicer, new laser and just cannibalize this one for parts… I’d just prefer not to spend $800+

Maybe this will visually explain it better. I know I’m not the greatest at text-splaining

Excuse the mess. One thing to note when I show the inside the control panel— That’s the new replacement board propped up, with the previously-functioning-board disconnected and mounted to the panel.

Yes, the video helps…

If the control board tells it to go 20 steps, it has no way to know that this has or hasn’t been done.

If your head can be easily moved around now, but not with the other boards, this indicates a non logic supply voltage issue. Something like the 12V supply not getting to the motors. You can also set this via software to not be locked, but it’s not the norm because if you move them the controller doesn’t know.


I’m surprised it never did a home operation during power up… Looked at a lot of these, if they could home, they did.

The machine is not worth much until it knows where it is… Hard to imagine it wouldn’t home on power up as a default. Kind of irrelevant here, but it should home when requested.

I can’t see the green lights very well, but I’d sugggest you go here and see if it helps. They know more about these than I do…

Whatever you find, please share :wink:

Good luck

:smile_cat:

Absolutely.

I’ll run through these smoothie stuff and report back

On the home at power on function, I do agree. The machine is lost in space until it homes. Most 3D printers and even the Haas CNC do a similar thing. For this particular machine, even with the other factory board and whisperer, it doesn’t home or energize the steppers until I connect and manually click “initialize laser cutter”

Not trying to muddy the waters with that anecdote, just clarify what the norm for this particular machine had been in the past

You aren’t… The original control board for these was an 8051, I used these back in the late 70’s. With these computer power is in the pc, not that control board. All these control boards do is count steps.


I would think any kind of real controller would home. It cannot operate without knowing where it is, awake and stupid is useless.

If you can swap out the boards and get a working machine, it must be the board you’re swapping.

Good luck

:smile_cat:

Edited due to post restriction—

Going to put this here in order to make it a little more concise, just in case anyone comes across this thread who is experiencing a similar or the same problem—

The short answer is- it was the config file, more or less. Whatever happened turned it into a jumbled mess.

However I think something wonky is going on with the old OmTech board’s SD card slot as well.

I tried the two SD cards through the old OmTech board and it wouldn’t connect with a fresh FAT32 format and fresh files. Oddly, the green LEDs stopped flashing with this setup, as well as my USB not being recognized.

Out of further frustration and to eliminate another variable I grabbed a new SD and again, formatted to FAT32 and dropped the files onto it.

Put that SD card into the new OmTech board, hooked everything in, powered up. BOOM. Homed immediately upon opening LightBurn.

So I think it’s something wrong with the card slot, that may of caused a short or whatever to corrupt the SD card? I dunno, but am glad it works. Thank you.

Video pretty much showing and explaining the same thing if you prefer visuals—

https://youtu.be/1r-UNFHjdmo?si=FLjfxGQw0IgxVDCK

According to OmTech the firmware file isn’t even needed

Again. Thank you guys so much.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.