Monport 40w keeps halting mid burn

I have an xtool and decided to add a monport and for some reason i cant get it to work quite right. I a having problems getting it to finish a job. It keeps halting and i cant figure out why. Any help would be appreciated! This is whats its saying after it has been halted.

G-code motion target exceedes machine travel. Machine position safely retained. Alarm may be unlocked. (Right click the Devices button to reset connection) on or near line 10862:
Job Halted
Stream completed in 6:15
[MSG:Reset to continue]
Grbl 1. 1f[‘$’ for help]
[MSG: ‘$H’ | ‘$X’ to unlock]
Grbl 1. 1f[‘$’ for help]
[MSG: ‘$H’ | ‘$X’ to unlock]
[MSG:Caution: Unlocked]

This is saying the command to move will put you beyond the max travel limit parameters. If your project fits inside yoir workspace, this could be caused by the head stopping distance after the burn.

It’s saying that there was code sent to it that would have caused the machine to be driven out of it’s defined working area…

This can be a couple of things… it could be overscan, the start from value is incorrect and/or the job origin is incorrect.

You don’t give us enough information to advise much else…

Did it work before? Did you change anything?

Is it a scan or vector engraving?

If possible can you post the .lbrn2 file?


Im sorry yes it has worked prior but no for long. Maybe a couple of times. Thishas happened since. I was cutting out earing so they are small and wel inside the cutting area. I tried homing it and then starting the project from there but even then im getting the same result. Is there any othr information that wouldbe useful?

The project file with the lbrn2 extension…

A screenshot of the device settings, and the cuts/layer gui…


Its done it on multiple files. These are the settings.

Which xTool model laser engraver did you begin with?

Did you Replace the xTool control board with the Monport control board?

Do you have limit switches and/or Homing switches or neither?

Did you key in all the Machine Settings from the xTool?

Please open the Console window in LightBurn and after you see the word ok request these reports by typing the following:


Pressing enter after each one. If you attempt to copy and paste them as a block it wont work.

You can however Select and Copy the text from the Console window and paste the entire batch of reports into a reply here.

The Monport controller may be set up for a 40W CO2 laser, A variant of the K40.

In the Move window in LightBurn, do the Jog arrows make the laser diode module move as anticipated?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.