Move buttons/Absolute Coordinate buttom

Can anyone tell me how to get the move buttons to work in lightburn with my D1 pro 20W? I also can not get the absolute coordinate button to move the laser to the position on the screen, which makes it impossible to figure out how to design on screen and cut accurately. The framing function is slightly off, and is not working correctly with the limit switches so it is cutting off part of what it says will fit on the workspace.

There are a few things happening here. Hopefully we can unpack this and get you going.

In LightBurn, with the xTool D1 Pro connected, open the Console Window, and the Move window. Using the Move buttons in the Move window allows LightBurn to know where the engraver head is. Using buttons on the engraver (when they are equipped with them) or physically shoving the laser head to a new place will likely cause the location information to become inaccurate.

If the Move buttons in the Move window aren’t working, please screen-capture the Move Window and the Console window so we can confirm communication is working and the distance and speed settings in the move window are reasonable.

Windows has a tool called Snip that will capture the screen. Please, drag and drop that picture into your reply.

I’m 98% sure the problem isn’t the Absolute Coordinate button - I feel that this is Move related and we’ll get this sorted with the diagnostic steps above.

This is interesting, and this may be the second comment of its kind this morning.

The limit switches can and do limit the engrave area. They are intended to reduce damage to the engraver caused when the engrave head crashes into the rail. This is all reasonable and expected.

If you are framing some work and the limit switches are causing problems then you are working outside the allowed space. If you shrink your art 5% and move it slightly away from the bottom left corner (where the limit switches are) this may jump that hurdle.

If you are framing with red cross-hairs instead of the diode laser dot there is an offset that can be challenging to configure. I would save setting up the cross-hairs for later in the interests of getting you going sooner. Framing with the blue dot is often more accurate.

To check one final thing please open the Console window and request a couple of reports by typing the following:
with enter after each report request.

It may look indecipherable but it’ll tell me a great deal about your xTool D1 Pro and if anything is unusual about the coordinates and limits. Please Copy and Paste the reports into a reply here.


1 Like


Thanks for responding @JohnJohn. I hope what I provided gives you some insight in to what is going on. I agree that the absolute coordinate button is related to the move function, I provided that info really to help diagnose what I have set up incorrectly. As far as the framing issue, I am framing with the crosshairs because I can’t seem to get the laser dot to come on in lightburn, even when I had the “laser on with framing” and “enable laser fire button” turned on in device settings. I am assuming that because the crosshairs are -16mm on the x axis, its framing ok, but then when it goes to cut its hitting the limit switch. Once we get the absolute coordinate situation figured out, that will no longer be an issue.

Apparently I had $J Jogging turned on and that wouldn’t let it move. The move function is now working and the absolute coordinate button is now working. Let me know if you see anything else that I should be changing in my setup though. Thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.