Move buttons are reversed and burning is upside down and/or reversed

I have a Grbl laser. All of my move buttons are going in reverse and when I burn something it burns either upside-down, backwards or both. I’ve tried to change the origin to the upper right rather than lower left and it did not change anything.

Which origin did you change - the job origin or machine origin?

Machine origin is in Edit > Device Settings, and for GRBL it should generally be in the front-left, assuming your machine follows standard conventions. If you changed this one and it didn’t affect anything it would be the first time I’ve heard of this.

Job Origin is 9-dots in the Laser window, and that just controls where the job is placed relative to the laser head.

Oz,
I have included pictures of how everything is set up and how it is burning. I hope this helps. As you can see I have the word set in the upper right corner at 100mm in size and it burns in the lower left corner at 5mm in size and upside down.

IMG_2377 IMG_2378

The position of the overall design is because you’re running in “Current Position” mode - Read this to understand what the different origin modes mean and how they work: https://github.com/LightBurnSoftware/Documentation/blob/master/CoordinatesOrigin.md#coordinates-and-job-origin

Since the text appears to just be vertically flipped, change the Origin setting in Edit > Device Settings from the lower-left corner to the upper-left corner. By choosing the opposite vertical corner, you’ll vertically flip everything. If you chose the opposite left-to-right corner, you’d flip everything left-to-right.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.