Multiple layer doesn't work (engrave entirely my model)

Hi All,

Tried to find this problem on the forum but did’t see anything about this problem I have.
I have a model, with two layers (one to engrave and one to cut). When generating Gcode individually for each layer, laser GRBL shows that everything is fine. But when i generate the GCODE in lughtburn with both layer at the same time, it engraves entirely the model instead of only the parts that must be engraved!
The preview shows well the model, engraving and cuting parts…but in grbl and when trying the Gcode, it’s not working. :frowning:
Does anybody knows why separatly the layers work fine, and when generating the gcode with both layers makes it fail?
Thanks all for any advices…

What else is in the design other than the two layers?

Can you include photos and screenshots of what you’re dealing with?

Hi,

Here are 3 screen shots from lightburn, and what is give checking in LaserGRBL…

And here the lightburn file
porte cle colibri.lbrn2 (244.6 KB)

And what is strange is that when i do a new file with two simple squares, that works fine!!

I don’t think I’m understanding the problem. Are you talking about how the image in LaserGRBL looks blurred? I believe that’s the traversal moves.

Have you tried burning this? I suspect it will burn fine.

What I am saying is that everytime i try to engrave/cut, it comes out all black…

And if I generate 2 Gcodes, one with each layer, laserGRBL shows that it will engrave fine, and cut fine…but with only one Gcode with both layer, it comes out entirely black…

Any idea why ?

How are you running this in LaserGRBL? Are you simply loading the gcode and sending to machine?

Have you tried running this in LightBurn? What happens?

Can you upload the gcode that’s failing here? You should a .txt extension to the end of the file for this to work.

Hi,

First thanks for your time…Here is the GCode.
I put it on the SD card and fid it to the laser cutter…
Haven’t tried to run it from laserGRBL or Lightburn.
porte cle colibri_en_M03M05.gcode.txt (107.4 KB)

I don’t see why the combination of the two layers makes everything goes wrong.

First thing I notice is that you’re using a Marlin profile.

If this is for Falcon machine? If so, that should be configured for GRBL. I suggest you create a new profile and try again.

I don’t see how even a single layer would work in this case. Did you try testing an actual burn with a single layer?

Hi,

I have a Falcon 10W and print from SD card…(I don’t use GRBL or Lightburn to send directly Gcode into the laser cuttter…and GRBL is just to visualise the expected result).

When I generate gcode for only the engraving part everything is fine :

And you’ve seen that when i generate gcode for both, everything appear as travels, and the laser stays on…burning everything.

Is there somewhere where I can find the best profile for my Creality Falcon 10W? I had used the marlin profile cause had’nt find the creality ones…

Thanks, this need to be tried with a corresponding profile for sure.

Have you tried actually burning this? I suspect it will burn everything.

I thought I was clear. You need to use GRBL profile. Push “Devices” button in Laser window and either attempt to “Find my laser” or create a new device manually with GRBL profile.

I’ll give it a try today and will let you know about the result.
Thanks

Hi berainlb,

Thanks for your help…and I hope this will help others…
I confirm that in Lightburn we have to select GRBL profile for the falcon 10W Creality.
It now works fine, and both layers are taken into account!!

We can close this subject! :smiley:

Cheers!!!