My engraver has once again started banging against the rail

Both motor drivers lights are green.

Good both lights are green.


Ruida → motor driver → motor

Each axes, has it’s own motor driver/motor and associated cable that needs step and direction signals from the controller or power to each phase of the motor.


If you swap the motor driver → motor cable and the problem moves, it’s the motor or cable.

If the above doesn’t change anything and you swap the control signals from the controller → motor driver and the problem moves, it’s from the controller onward… I.E. controller or cabling…

Make sense?

:smile_cat:

Hooked up an oscilloscope to the output of the mother board and the signals are identical. Looks like its the motor. Switching drivers does not change the problem. Looking for a source for replacement motor if you have one. Thanks.

You shouldn’t need to drag out a scope… Just swap the cables between the motor drivers and the motor.

If nothing changes, it’s the motor or the cable…

:smile_cat:

Yes, I switched the 4 pin cables and the same motor is causing the issue. X motor fine, Y motor same problem. Tks. Do you have a source for motors?

I put the scope on because I thought there might be a corrupted signal. All was well.

Haven’t used a scope sense my days working on the Titan, Atlas and Gemini capsule. Before that II worked with Orville and Wilber.

Find out what kind of NEMA motors they have…

A NEMA23 is 2.3" on each side a NEMA17 is 1.7" on each side…

Then search the Internet…

Data-Sheet-Stepper-Motor-Support.pdf.txt (839.0 KB)

Good luck

:smile_cat:

2.3" on each side.

Search for NEMA23. Is it in the back so it needs a shaft out both ends or a single end output?

It’s what we all do… I can’t tell what it physical output shafts are, that’s up to you… hunt them down on the Internet.

If you want to wait someone may drop in and make a suggestion… but it might not work too well if you need it shipped to Australia.

Good luck

:smile_cat:

I’m in Az. No shaft on back.

This is my Y motor. I has a shaft to the belts on each side of the Y carriage. Taken through the material pass through on my OMTech China Blue…


Down the road a piece from you in Camp Verde… :crazy_face:

:smile_cat:

Thanks for your help. Found a motor and looks like it is in spec. I am using my old K40 to try to keep production going but it’s slow but it does a good job.
NF

Wow!. I live in Prescott. Must meet some time. For what do you use your equipment?
Thanks again for your help.

Had a little CNC3018 I was playing with and, like a dummy, I hung a laser off it…

Then I progressed to a co2 to learn more about how they work… that evolved into a fiber…

Mainly to learn about them … still learning… :crazy_face:

:smile_cat:


My Y motor

I can’t really tell much from the photo… you can google the numbers on the motor and see what you get…

:smile_cat:

Yeah, did that and found one just about 1/4 in longer but all specs seem OK. ordered it hoping to get it next week. Still looking for exact match.

(a) If understand correctly you switched the X and Y output signal plugs at the Ruida control board?

which (b) made the poor movement shift to the X-axis? - And presumably at that point the Y axis worked fine (when using the X-jogging button)?

But later (c) you switched only the motor output wires and the poor movement stayed with Y axis - leading you to suspect the Y-motor is at fault?

Your conclusion from (c) is at odds with (b).

The results at (b) and (c) point towards a control board problem, or most likely a problem with the Y-axis settings, the motor will be fine.