My laser stops after 10s of cutting

Hello,

I have a probleme using my laser because it stops everytime we I am running the programme after only 4 second of cutting wich is a bit annoying since I need to cut big volume of fabric.
It is very weird because it has been working for at least 3 days in a row and sometime at the end of the day. But now I am completly stuck.
In addition I have tried to copie paste the G-code into the openbuilt software and it still doesn’t work.
I have also change the options of the power plant to be able to disable the USB selective suspend setting and nothing changed.

It would be very kind of you to answer me.

Have a nice day

LTDLN

What machine do you have? :crazy_face:

I hope those photos will help you answer your question !


Is it exactly 4 s or “after a few seconds”?

Does the machine continue moving with the laser off or does the whole machine shut down?

Is that with the same G-Code file or with different patterns?

More details will help figure out what’s going wrong.

Yep absolutely thanks for you answer.
It’s around 5s after the laser is active and then both the motors and the laser stop working.
With the G-Code we need to “unpause” the code because it pauses each 10s.
In addition when the laser and the movement stops the programme continue to run by itself.
Tell me if those information can help you.

Really stupid but, sometime when I’m struggling I don’t always see the little things, that being said, just in case, have you restarted both the computer and laser? and start all over again? secondly, this is one I’m very guilty of, I forget to set my Z height, and my laser errors out because of the flame sensor. Its probably not that but sometimes you just never know what it could be. Hope you get it working.

We have restarted both the controller and the laser. Morover our z axis is fixed so it doesn’t move and I don’t even think that there is any sensor on the laser.
We even hesitated to shut down the electricity of the hole building down because we are desperate.

I’m not quite sure how those relate. Do you mean LightBurn’s progress indicator?

This sounds very much like the usual USB communication glitches due to crappy cables, dubious power supplies, and suchlike. Although you have a different controller, going down through the whole checklist will probably give you some improvement:

Although it sounds like shaking the dice until a better combination comes up, nominally “good” USB cables can be crap inside. Although a cable with ferrite cores may seem like witchcraft, the additional cost of the cores tends to get you a better-quality cable and that can make all the difference.

A marginal power supply can brown out the controller and force a reset under what seems like normal operation. To size the power supply, add up:

  • The peak current for all the stepper motors
  • The input current for the laser head
  • 1 A for the controller and other frippery

Double that number and buy a power supply rated for that current. My guess is whatever you’re using now is half of what you need: works fine under most conditions, browns out in the peaks.

Basically, you’re almost all the way there, but finding & fixing the last problem will take as much time as you’ve put into the thing already. :grin:

2 Likes

I’m on ‘Team Marginal Power Supply’. Restart behavior should be evident in the Console window.

Do you see any messages appearing in the Console window at about when the device suddenly stops? If there is nothing obvious, click the switch on the right side of the Console window and switch on ‘Show all’. it will show the communication between the engraver and LightBurn. If you have verbose reporting selected in your controller, it may be swamping the communication and dropping the USB.

Please select and copy text from the Console window in LightBurn and paste it into a reply here. I am very interested in the first connection messages from the controller to LightBurn. It will tell us which Firmware, when it was programmed, and which build options are built in.

Have you recently increased speed and laser output just before it stopped working?

Have you changed any electrical cords, locations or positions of this equipment or any equipment plugged in nearby? Nearby window air conditioning units and fans can cause USB communication problems.

1 Like

Okay it seems that changing the cable made the difference because it works fine now but I will keep you in touch if it doesn’t work again.
Thank you for your help guys !

Is it fully bonded and grounded? Static (generated by the belts and rollers) stops these gantry machines dead in their tracks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.