My Mac book pro is not connecting

I’ve read the other threads. I have a MacBook Pro. Working fine before the update, now it’s not working. The laser is powered, but it says disconnected and laser won’t move, won’t test fire… it’s as if there is nothing to drive it. If I choose cu.Bluetooth-incoming it states it’s ready but still nothing. See photos



Also, the move button is gone.

Kim

I reloaded my device and now it’s moving the laser but the fire button is gone and no light is coming from the laser

Kim

As of now, I’ve figured it out!!! It’s working.

Kim

??? Can you please share what this means, technically? Helpful for others that may wander by. :slight_smile:

Well, I’m not sure it’s fixed permanently, actually. I had to reload my laser in light burn. It gave me the correct com port to connect to on the dashboard. Everything worked. I shut down, went to work, now I’m home and want to continue my project and again, I don’t have the correct com port, so I had to reload my laser AGAIN, and then it worked. Just shut down again. I’m going to see if it’s recognized once I turn it on again.

P.S. I’m not very technically adept, so I can’t get much more technical than that. I was just playing around trying to figure things out and stumbled on this problem.

@Katf you are doing fine, providing exactly the information needed. Thank you. Please do keep us updated about this test. You may need to select the proper port to have LightBurn connect correctly. What do you see in the drop-down to the right of the ‘Devices’ button?

Thank you! I don’t have that auto button like your screen shot has. I currently have my machine loaded twice. It works that way, as soon as I Remove one of them I lose the correct com port. This picture shows the correct port. It works, but if I try to remove one of the lasers I lose this.

image

Where the red box is, you can click, and choose among any ports connected to the machine, and you likely have a couple different ones, only one of which will be connected to the Ortur.

If you show the Console window, then pick a port and look in the console, you’ll either see “Waiting for connection…” or you’ll see some text from the Ortur controller like “GRBL 1.1f [$ for help]” and so on. When you see that, you have chosen the right port, and LightBurn should remember that selection for next time.

That’s the problem. Since I updated this morning, it’s not there when I turn it on. There are three options, pictured in my first post, none of them power the laser. I have to re-search for my laser and then the correct port is available. But, once I turn it off and go back, it doesn’t hold the info and I have to go through the steps again. Also, I have to keep resetting the fire button. I go in, turn it on, turn off the system, reset my laser and the fire button is active. Then after I’m done with that session and I come back I have to go through all the steps again. Very aggravating.

Thanks,
Kim

You should never have to re-search for the laser. If you power the laser FIRST, then run LightBurn, the port should be there - this is the preferred way.

If you run LightBurn, THEN power the laser, right-click the ‘Devices’ button and that will re-build the list of available ports - You won’t have to redo the search. (you can also click ‘Devices’ then just click ok - it does the same thing)

The reason you have to re-enable the Fire button is LightBurn thinks you’re adding a NEW laser, and that’ll be a different profile with different settings. If you just make it use the old profile with a different port, it doesn’t do that.