My machine wont find home, unless its after a job?

My atomstack x30 pro with a laser bed of 400x800 and limit switch at bottom left will not go home if it is me telling it to, but if i move it manually to home, then start a job, it completes it, then goes back home all on its own. thats the only time it will go home.

Console text after last job :
G0 X8.6479Y10.0031
Layer C02 Pass 1 of 5
G1 X8.607Y10.0192600F39.37
G1 X8.5671Y10.0372
G1 X8.5283Y10.0571
G1 X8.4906Y10.0788
G1 X8.4541Y10.1022
G1 X8.4188Y10.1273
G1 X8.3848Y10.154
G1 X8.3522Y10.153
G1 X8.3209Y10.2111
G1 X8.2911Y10.2434
G1 X8.2628Y10.276
G1 X8.2361Y10.31
G1 X8.211Y10.3453
G1 X8.1876Y10.3818
G1 X8.1659Y10.4195
G1 X8.146Y10.4583
G1 X8.128Y10.4982
G1 X8.1119Y10.5391
G1 X8.0978Y10.5809
G1 X8.0856Y10.6236
G1 X8.0756Y10.6671
G1 X8.0677Y10.7114
G1 X8.0619Y10.75
G1 X8.3522Y11.5147
G1 X8.0619Y10.7565
G1 X8.0585Y10.8022
G1 X8.0573Y10.8485
G1 X8.0585Y10.8948
G1 X8.0619Y10.9405
G1 X8.0677Y10.9856
G1 X8.0756Y11.0299
G1 X8.0856Y11.0734
G1 X8.0978Y11.1161
G1 X8.1119Y11.1579
G1 X8.128Y11.1988
G1 X8.146Y11.2387
G1 X8.1659Y11.2775
G1 X8.1876Y11.3152
G1 X8.211Y11.3517
G1 X8.2361Y11.387
G1 X8.2628Y11.421
G1 X8.2911Y11.4536
G1 X8.3209Y11.4849
G1 X8.3522Y11.5147
G1 X8.3848Y11.543
G1 X8.4188Y11.5697
G1 X8.4541Y11.5948
G1 X8.4906Y11.6182
G1 X8.5283Y11.6399
G1 X8.5671Y11.6597
G1 X8.607Y11.6778
G1 X8.6479Y11.6939
G1 X8.6897Y11.708
G1 X8.7324Y11.7202
G1 X8.7759Y11.7302
G1 X8.8202Y11.7381
G1 X8.8653Y11.7439
G1 X8.911Y11.7473
G1 X8.9573Y11.7485
G1 X9.0036Y11.7473
G1 X9.0493Y11.7439
G1 X9.0944Y11.7381
G1 X9.1387Y11.7302
G1 X9.1822Y11.7202
G1 X9.2249Y11.708
G1 X9.2667Y11.6939
G1 X9.3076Y11.6778
G1 X9.3475Y11.6597
G1 X9.3863Y11.6399
G1 X9.424Y11.6182
G1 X9.4605Y11.5948
G1 X9.4958Y11.5697
G1 X9.5298Y11.543
G1 X9.5624Y11.5147
G1 X9.5937Y11.4849
G1 X9.6235Y11.4536
G1 X9.6518Y11.421
G1 X9.6785Y11.387
G1 X9.7036Y11.3517
G1 X9.727Y11.3152G1
X9.7487Y11.2775
G1 X9.7686Y11.2387
G1 X9.7866Y11.1988
G1 X9.8027Y11.1579
G1 X9.8168Y11.1161
G1 X9.829Y11.0734
G1 X9.839Y11.0299
G1 X9.8469Y10.9856
G1 X9.8527Y10.9405
G1 X9.8561Y10.8948
G1 X9.8573Y10.8485
G1 X9.8561Y10.8022
G1 X9.8527Y10.7565
G1 X9.8469Y10.7114
G1 X9.839Y10.6671G1
X9.829Y10.6236
G1 X9.8168Y10.5809
G1 X9.8027Y10.5391
G1 X9.7866Y10.4982
G1 X9.7686Y10.4583
G1 X9.7487Y10.4195
G1 X9.727Y10.3818
G1 X9.7036Y10.3453
G1 X9.6785Y10.31
G1 X9.6518Y10.276
G1 X9.6235Y10.2434
G1 X9.5937Y10.2121
G1 X9.5624Y10.1823
G1 X9.5298Y10.154
G1 X9.4958Y10.1273
G1 X9.4605Y10.1022
G1 X9.424Y10.0788
G1 X9.3863Y10.0571
G1 X9.3475Y10.0372
G1 X9.3076Y10.0192
G1 X9.2667Y10.0031
G1 X9.2249Y9.989
G1 X9.1822Y9.9768
G1 X9.1387Y9.9668
G1 X9.0944Y9.9589
G1 X9.0493Y9.9531
G1 X9.0036Y9.9497
G1 X8.9573Y9.9485
G1 X8.911Y9.9497G1
X8.8653Y9.9531
G1 X8.8202Y9.9589
G1 X8.7759Y9.9668
G1 X8.7324Y9.9768
G1 X8.6897Y9.989
G1 X8.6479Y10.0031
M9
G1 S0
M5
G90
G0 X0Y0
M2
[MSG:Program End]
Stream completed in 0:48

then it homed on its own.

i move it towards the back, and hit home again, and it goes all the way to the left then stops, will not go back or forwards. and says this

$H

ALARM:8

Homing fail. Cycle failed to clear limit switch when pulling off. Try increasing pull-off setting or check wiring.

ok

Grbl 1.1h [‘$’ for help]

[MSG:Check limits]

[MSG:‘$H’|‘$X’ to unlock]

$X

[MSG:Caution: Unlocked]

ok





Going to 0,0 (Finish Position) is not the same as Homing.

Does your machine have limit switches on both ends of the X and Y travels? If not, turn off $21 and turn on $20.

Do you have limit switches at all? If not, turn on the $22 parameter.

Now come back and tell us what, if any, problem it is having. There is another parameter or two, but we need more info before changing those.

I think you mean “turn off” to prevent homing without the required home switches.

Sorry for the delay, I am ready to get this fixed, so do I need to turn off $22? Or turn it on? I have a switch at home, which is the bottom left on the Y axis. No other switches.

I have one limit switch at the bottom left on the Y axis. I followed your instructions and turned off $21 and turned $20 on. Still did the job and went back to 0,0. If i send it to somewhere on the bed then hit the home button it will go all the way to the left on the x axis but will not move down the Y at all, and produces this in console

Homing fail. Cycle failed to clear limit switch when pulling off. Try increasing pull-off setting or check wiring.
ok
Grbl 1.1h [‘$’ for help]
[MSG:‘$H’|‘$X’ to unlock]
[MSG:Caution: Unlocked]
ok

There are two reasons this can happen
a) you wired the Y switch wrong, is NO and you set it to NC
b) is related, if the switch is broken

Meaning the machine wont home on Y because is already getting a “Touched” signal
if this is right however you should see a little pull back at the end of the failing homing

Test is easy. Unplug the switch all toguether, and try again

Okay, so I’m going to unplug the Y limit switch. Leaving the $20 and $21 setting how I have them from the previous instruction. Then have it go somewhere on the work area then try and press home and see what happens?

the power up home should already show a different behaviour when Y switch
is unplugged

There are at least 2 switches, you just don’t see it. It makes no sense to h
HOME only one axis.

And yeah, I meant $22=Off.




well i circled the only switch i see and the other corners have nothing else like that, or anywhere else on the machine.

The other switch will be on the gantry, where the laser head can activate it.

Oh, you are a genius. Yes, there is one on the gantry, I’m assuming that is the x axis switch, I followed the other guy’s instruction and unplugged the one, and what I thought only switch, I hit home and it started going down the y axis and as you would assume, ran into the unplugged switch. what would you guys recommend i do next?

So there is two total switches, one on the left of the gantry, and one of the bottom left of the railing

That is what I tell everybody, but we both know that is not true. :joy:

Leave $22=0.
First the Xaxis:
Manually put the Xaxis about 2" off the limit switch.
In the Move window, seet the Speed to 500mm/m.
Power up the laser. It should just sit there with no alarms.
Slowly Jog the Xaxis onto the switch. You should get an over travel alarm before you hit the frame.
If not, the switch is bad.

Jog or move off the Xaxis switch.

Yaxis:
Repeat the above steps for the Yaxis. No alarm on power up, alarm when you hit the switch.

If You pass these, then enter $$ in the Console window. Copy and paste the results in the Reply window. Examining GRBL parameters is next, followed by some more diagnostic moves.

i got the code on both … i think

Waiting for connection…

Waiting for connection…

ok

[VER:1.1h.2022070601:]

[OPT:VZ,15,128]

Target buffer size found

ok

$0=10

$1=25

$2=0

$3=0

$4=0

$5=1

$6=0

$10=1

$11=0.010

$12=0.002

$13=0

$20=1

$21=0

$22=1

$23=3

$24=300.000

$25=3000.000

$26=250.000

$27=1.000

$30=1000.000

$31=0.000

$32=1

$37=1

$40=2

$100=80.000

$101=80.000

$102=80.000

$103=100.000

$104=100.000

$105=100.000

$110=6000.000

$111=6000.000

$112=6000.000

$113=1000.000

$114=1000.000

$115=1000.000

$120=1000.000

$121=1000.000

$122=1000.000

$123=200.000

$124=200.000

$125=200.000

$130=400.000

$131=400.000

$132=200.000

$133=300.000

$134=300.000

$135=300.000

ok

ok

ets Jun 8 2016 00:22:57

rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)

configsip: 0, SPIWP:0xee

clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00

mode:DOUT, clock div:1

load:0x3fff0018,len:4

load:0x3fff001c,len:1044

load:0x40078000,len:10124

load:0x40080400,len:5856

entry 0x400806a8

Grbl 1.1h [‘$’ for help]

[MSG:Local access point Engraver_57413 started, 192.168.4.1]

[MSG:HTTP Started]

[MSG:TELNET Started 8080]

Grbl 1.1h [‘$’ for help]

<Idle|MPos:0.000,0.000,0.000|FS:0,0|Pn:PY|WCO:0.000,0.000,0.000>

ok

Starting stream

ALARM:2

G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)

On or near line 0:

Stream completed in 0:00

ok

Grbl 1.1h [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]

ok

Waiting for connection…

Waiting for connection…

ok

[VER:1.1h.2022070601:]

[OPT:VZ,15,128]

Target buffer size found

ok

<Idle|MPos:0.000,0.000,0.000|FS:0,0|Pn:PY|WCO:0.000,0.000,0.000>

ok

Starting stream

ALARM:2

G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)

On or near line 0:

Stream completed in 0:00

ok

Grbl 1.1h [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]

ok

ets Jun 8 2016 00:22:57

rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)

configsip: 0, SPIWP:0xee

clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00

mode:DOUT, clock div:1

load:0x3fff0018,len:4

load:0x3fff001c,len:1044

load:0x40078000,len:10124

load:0x40080400,len:5856

entry 0x400806a8

Grbl 1.1h [‘$’ for help]

[MSG:Local access point Engraver_57413 started, 192.168.4.1]

[MSG:HTTP Started]

[MSG:TELNET Started 8080]

Grbl 1.1h [‘$’ for help]

<Idle|MPos:0.000,0.000,0.000|FS:0,0|Pn:PY|WCO:0.000,0.000,0.000>

ok

Starting stream

ALARM:2

G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)

On or near line 0:

Stream completed in 0:00

ok

Grbl 1.1h [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]

ok

<Idle|MPos:0.000,0.000,0.000|FS:0,0|Pn:PY|WCO:0.000,0.000,0.000>

ok

Starting stream

ALARM:2

G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)

On or near line 0:

Stream completed in 0:00

ok

Grbl 1.1h [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]

ok

$$

$0=10

$1=25

$2=0

$3=0

$4=0

$5=1

$6=0

$10=1

$11=0.010

$12=0.002

$13=0

$20=1

$21=0

$22=0

$23=3

$24=300.000

$25=3000.000

$26=250.000

$27=1.000

$30=1000.000

$31=0.000

$32=1

$37=1

$40=2

$100=80.000

$101=80.000

$102=80.000

$103=100.000

$104=100.000

$105=100.000

$110=6000.000

$111=6000.000

$112=6000.000

$113=1000.000

$114=1000.000

$115=1000.000

$120=1000.000

$121=1000.000

$122=1000.000

$123=200.000

$124=200.000

$125=200.000

$130=400.000

$131=400.000

$132=200.000

$133=300.000

$134=300.000

$135=300.000

ok

image

Note after homing your machine reports Mpos X0 Y0 Z0
So it homes correctly

The next alarm 2 must be based on something else
Cna you post a full screenshot of your lightburn so we can see the design and laser pannel too?

Also image of your Edit _> device settings
And your layer settings

1 Like

Ok so the issue is you have an extended frame (as per your Edit → device settings)
But your firmware is NOT aware of that
You will need to do $131=830 press enter (change 830 to whatever value is correct to you)
Once done, try again

P.S. Awesome machine name! hahah

1 Like

i have done this before but just forgot tot do it again when i reset after i took my camera off and reset. and the problem persisted. but i will try this again, i really appreciate the help. and thanks lol its my houses “name” (my street) :sweat_smile:

do i turn 22 back on ?