My Ortur 2 S2 laser wont turn on

hi there , i did stupid thing and tried to upgrade my Ortur 2 S2 laser firmware and now it wont turn on.
when i press power and reset button it comes up on my computer to put firmware in but when i turn that off it wont power up.
ive started Lightburn and did this to see if Lightburn would see the laser but it says it isnt conected
can i please get some help as it was working ok before this and i dont want have to buy another one

What happens if you hold down the lower button? Mine takes as long as a five-second press to turn the laser on after the last time I updated the firmware.

Hi thanks for the reply, I found the problem, it was me, when I downloaded the firmware file it was in zip format, when I double clicked on it it showed me the bin file so I copied it across, however double clicking on it doesn’t unzip it.
When I unzipped it it all worked good, thanks anyway :blush:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.