Need help jog wont work after accidentally hitting reset on machine

Hello
All was well until during a set up i accidentally hit the reset button on my machine and closed ouy streaming in lightburn software. Then the jog stopped working when i went back into software . So i went into grbl and input all settings as i gad them previously and went back into lightburn. Jogging works in grbl but not in lightburn now. I need help to fix this please .



I have a 3018 and had a similar problem.

Close out of LaserGRBL for now and fire up LightBurn.

Have a look in the Console window and see if LightBurn is saying “Waiting for Connection”. If it’s stuck (as mine was this morning), and you have selected the correct Com port and it’s still not communicating: Have a look for another ‘instance’ of LightBurn Running. If one hidden instance of LightBurn is working and running and connected it will prevent another (active) one from communicating on the desired Com port.

Which reset button did you accidentally hit?

Hello , I hit the one on the control board right beside the on off switch.

I did shut down and restart my whole computer just in case there was any sort of inactive window issues thinking that maybe would close any open ones out.

image

1 Like

Ok, great - you’re connected to the laser. Try the jog operations in the Move window. Make sure the number is bigger than 5 or 10 so you can see it. if i pick 3 or less and I can’t always tell for sure.

Frame is also a good go-to if you have a project loaded.

Have fun. Please report back if it’s still not doing what it needs to do. :slight_smile:

Issues still continued. I cannot jog left in lightburn . And when i try to set origin current pos. And frame an area it goes from the left bottom pos. I set all the way over and back. Not framing the area i asked it to. It really backwards and confused and apparently on strike …funny not funny :frowning: idk what to do i uninstalled reinstalled rebooted ect . What is left?

Does alarm 3 reset while in motion grbl cannot guarantee position lost steps likely have anything to go with this issue im having .

I don’t blame you for venting - learning is a challenge even when you love new stuff and crafting…

This is great - I’m glad you captured this.
Maybe I can try to be funny - not funny. :slight_smile:

The engraver could be confused and think it’s up against an imaginary wall and like Derek Zoolander - Can’t turn Left. :upside_down_face:

Go to the console window and type the following:
$#
then hit enter
Copy and paste the reply from the console into a reply here.
Edit: You did this a couple of days ago but it might have moved.

This little trick tells us where the controller thinks it is, and where it thinks the limits are. I have seen errors so large that I’d like to form a ‘Mile High or Mile Out Club’ for engravers. (1,609,344mm in a mile)

While you’re there. Do the same with $$ in the Console window. $10 (equals something) is a setting that can change how the previous coordinates are handled and $130,$131,$132 tell us how far apart the imaginary walls are.

:slight_smile: $#
[G54:93.200,-0.000,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:0.000,0.000,0.000]
[G59:0.000,0.000,0.000]
[G28:0.000,0.000,0.000]
[G30:0.000,0.000,0.000]
[G92:0.000,0.000,0.000]
[TLO:0.000]
[PRB:0.000,0.000,0.000:0]
ok

$#
[G54:93.200,-0.000,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:0.000,0.000,0.000]
[G59:0.000,0.000,0.000]
[G28:0.000,0.000,0.000]
[G30:0.000,0.000,0.000]
[G92:0.000,0.000,0.000]
[TLO:0.000]
[PRB:0.000,0.000,0.000:0]
ok
$$
$$
$0=10
$1=25
$2=0
$3=0
$4=0
$5=0
$6=0
$10=0
$11=0.020
$12=0.002
$13=0
$20=0
$21=0
$22=0
$23=0
$24=25.000
$25=500.000
$26=250
$27=0.000
$30=1000
$31=0
$32=1
$100=800.000
$101=800.000
$102=800.000
$110=1600.000
$111=1600.000
$112=1600.000
$120=5000.000
$121=5000.000
$122=5000.000
$130=290.000
$131=170.000
$132=40.000
ok

I was just able to burn in :LaserGRBL without the same issues as when im in Lightburn. But i really dont use lasergrbl but as only a control software.

I see nothing in software that would do what you’re describing.

I see one weird number in G54 and it’s not awful but let’s nuke it. :smiley:
In the console window type:
$RST=#

See if that solves the strange jog-left behaviour… I might add that strange number into my machine to see if i can make it misbehave.

Is it (was it) just jogging left that doesn’t work and jogging right works as predicted?

Most laser engravers are set up with 0,0 on your right hand side and at the back corner. does this line up with the way you’re working?

Let me know what happens next. :slight_smile:

I was able to move 30mm to the right then it stopped again then 30 mm to the left . This was after the code above was put in.

What message (if any) came up in the Console window in LightBurn?

Are you jogging with a hand control on your engraver?

if so, turn the engraver off (power cord), unplug it from the computer (other source of power) and disconnect the hand control (in that order)

From what you’ve posted - I would think the hand control wouldn’t be connected but I just wanted to double-check.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.