'Negative image' in cut/layer, not acting as expected

LightBurn 1.1.04, built Tue 2022-03-29 @ 14:31

Distributor ID: Ubuntu
Description: Ubuntu 20.04.4 LTS
Release: 20.04
LightBurn 1.1.04

I thought I understood this, but I’m not getting the expected results.

I have an owl dxf, that has been converted by Lightburn to a bitmap with 508 resolution.

I’m doing this on the back of a mirror by removing the reflective coating.

I would like to leave the mirrors reflective coating where the preview shows white. Notice the ‘invert’ is selected auto-magically in preview when ‘negative image’ is selected in the layer.

I selected ‘negative image’ in the cut/layer.

Without ‘invert image’ on the preview it’s the same… Does the same on the machine… with or without the ‘negative image’ selected…

owl-mirror-upload.lbrn2 (2.7 MB)

Original dxf file, don’t forget to rename it… :slight_smile:

owl-original.dxf.txt (1.3 MB)

Thanks…

:smile_cat:

Hi Jack! Too funny I have done that exact image lol. I had to get rid of the background. Let me see if i can find it and i will send it to you.

Probably not the reply you want. I traced the image then drew a box around the owl.


I would have thought the ‘negative image’ would be the correct way to handle it.

Never dawned on me to ‘trick’ it that way… :crazy_face:

The original that I posed was a dxf file and there was no background… or maybe that was my problem.?

Thanks

:smile_cat:

Owl Design.lbrn2 (252 KB)
Try this! Unless you want the negative look!

Iwas going for the 3D look this is what it looked like!

1 Like

I didn’t get a usable or good ‘preview’ of the boxed one. I tried fill but it just wiped out the image…

From what I understand the ‘negative image’ switch should reverse this…

:smiley_cat:

Just took a look. I think there are a couple of things going on.

  1. there is actually no white surrounding the converted bitmap. It’s transparent. So it seems the negative of transparent is transparent, not black.
  2. the bitmap is gray, so the negative of the gray is more gray, not white.

I think @micrololin’s approach of sticking with the vector format is straightforward. Place a square behind the vector to negate the image. Alternatively, convert to bitmap outside of LB and make sure you have a white background, then negate in LB. Or make the negative bitmap outside of LB.

This is what I got using the DXF and square. Seems to preview ok.

owl2-original.lbrn2 (837.9 KB)

He is a clean image without the background

If you ‘unclick’ invert image in the preview, it hasn’t changed.

:smiley_cat:

Weird it goes from white owl to black on my computer.


Is ‘Negative Image’ selected in the layer?

That appears to ‘turn on’ ‘invert’ in the preview.

:smile_cat:

It’s not an image

That’s part of the problem it not being an image. I need a bit ‘fatter’ lines and used an offset at one time, then to the ‘bitmap’.

The line leaves such a small line it’s difficult to use.

I’ll have to drop it into gimp and see what I can do with it… as @berainlb suggested.

Thanks… When I get a resolution, I’ll post it…

:smile_cat:

I was messing with this a bit more. During inverted preview I saved image. The saved image was saved as negative. Maybe another option?

Never crossed my mind to do that. I will attempt it as soon as I can. Life has come between me and the laser at the moment… Thanks

:smile_cat:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.