Negative space on rastered graphics suddenly engraves black since update to 9.17

I use an iMac, and yesterday I updated LightBurn to version 9.17. Suddenly, I have a new and serious problem.

I do a lot of work with superimposed raster graphics and vector cuts. Below is an example of a finished piece, followed by a screenshot of the elements in LightBurn that created it (the rastered image and the vector pattern) both superimposed, and separated.

Before I imported my graphic into LightBurn, I used a separate design application to delete the white space so that the image would become transparent but for the actual design. I did this to make it easy to manipulate in LightBurn, and to ensure that I was able to mate it precisely with the corresponding vector pattern.

The technique has worked so well that it has become the bedrock of my engraving work. I have plenty of finished designs created just this way, that all have been “plug and play” without trouble whenever I need to run them… until today, on the new upgrade of LightBurn.

Suddenly, the negative space in my graphics, where the white areas were deleted, wants to engrave black. Below are the very same graphic elements shown above, in a screen shot from LightBurn’s preview.

I tried running the graphic on my laser (K40 with C3D LaserBoard) to see whether the problem was just in preview, but it ran just as pictured in the preview.

I changed no settings. Screenshots of my line and image settings are below.

I was able to establish that the problem is not file corruption. I uploaded two different versions of the same graphic: one with white space deleted as per my customary practice, the other with the white space intact.

Then, I previewed them. This screenshot of the preview shows that it is the negative space within the included graphic that is the issue; LightBurn has begun interpreting it as black, since the upgrade. Smaller contained areas within the left-hand graphic where I never bothered deleting white space show up fine within it.

I decided to try and live with that at least temporarily, by replacing some of my interior graphics with non-negative-space versions… but that seems to have turned into a non-starter for me. I require precise sizing and alignment for my design to work, and suddenly I can’t see to do it! Copying the old vector and pasting it again doesn’t make it appear over the graphic. Nothing I have played with in the edit settings manages it, either. In the screenshot below, you can see my problem.

I really, really don’t want to have to redo every [expletive deleted] thing in my library because the newest version of LightBurn somehow changed the rules; and to the extent that I do, at least in the short-term, I need not to be shut down from creating and modifying precision designs. I’m developing products for a new Etsy store, and right now this problem is putting me into partial shutdown.

I am grateful for any insight, solution or other assistance you can offer.

If you are convinced that your problem is related to the last update and it is critical to your production, it is probably best to go back to your last working LightbBurn version.
There will always be some minor issues with a version change, therefore it is important to have a working backup and the latest working version of the program itself to avoid dangerous situations. ( you can also find an older version on LightBurn’s Homepage.)

Thank you, thank you, and thank you! I never imagined it would be possible to “regress” my version, let alone that it would be easy… but it was a snap. Your advice was spot-on. And yes, the problem I experienced totally arises from the revision; below is a new screenshot of the “white removed” and “white left in” versions of my snowflake graphic in LightBurn preview, after having re-installed the prior version. No problem at all!

Now I’m unburnt, and I can once again create snow with fire!

It would still be helpful to know if LightBurn will be addressing this issue for the next update, so I know whether I should install further upgrades or instead just stick with what works.

You can be absolutely sure of that. I think the LightBurn people take it as a challenge to make their fine program as stable as possible, for all the different types of laser machines.

No argument there! Thanks again for pointing me right.

I suspect this is fixed, but I can verify it if you can email that file to

We had an issue related to transparency / cropping / and the new rasterization engine changes to support these. Already fixed for the 0.9.18 patch release, but I’d like to verify if I could.

Thanks for getting back to me. I just emailed the file to you.

The 0.9.18 update is out already - you can try it yourself now.

You can now try this for yourself.

Verified fixed.

Woo hoo! Thank you so very much. I am impressed and grateful.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.