Negative workspace

I did some upgrades and may have tried to make too many changes at one time.

I installed limit switches and they seem to be working fine, but I also changed the stepper motors and my Y axis is in negative workspace with X in positive. (WTF??) I tried using the negative workspace offset, with Y as -180 and X as 0, but it still doesn’t work.
GRBL 1.1



You wired it backwards. you don’t need to fix in software - just wire it the right way round.

If it’s a plug, rather than discrete wires, you can set the axis direction in firmware.

That makes sense, it is a plug, but I don’t know how to set the direction in the firmware.

Most stepper plugs aren’t keyed - can you plug it in the other way round?

If not:

Wasn’t able to follow that very well, my Cantonese is sketchy. :slight_smile:

If I swap the plug around, then the motor doesn’t home in the correct direction, I was thinking I may just move the motor to the other end of the lead screw. I will be changing the screw next week when I swap the 180 for a 500, and can relocate the motor at that time.



You can change the direction in your firmware

I kinda figured that it was possible, but I don’t know how, and have not been able to find instructions that are clear enough for me to understand.

So I am looking for for some guidance from the more knowledgeable members of the community, which was the reason for making this post in the first place.

We use google, here. You can search for stuff like ‘how do I reverse axis on a 3018’. Its really useful.

For example, if you want to invert the X and Z axes , you’d send $2=5 to Grbl and the setting should now read $2=5 (step port invert mask:00000101). This setting inverts the direction signal for each axis .

Thanks for the help.

My attempts at google lead to unusable instructions such as the Chinese video. Perhaps I gave up too easily, but being a total noob at this I decided to ask for help, kinda the reason forums like this exist.

So I guess I have to take my licks along with whatever help I can get.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.