NEJE MSTER 2s Plus, Need installation tutorial

Hi guys, I have the NEJE master 2 plus 30W, I’m looking for tutorial for Lighburn installation.

Here is a tutorial:

You can follow it through and your NEJE will be working with LightBurn afterwards - albeit with very slow movement. This is because the tutorial is for the 2s and not the 2s Plus. Read the following thread on how to change the configuration for the 2s Plus.

Thanks, I’ii give a try.

Hi, I followed the tutorial and it is as follows: it recognizes the homing when it moves it makes a lot of noise. How can I solve the noise problem? Can you post your Neje Device Profile? Thanks.
I’m sorry for my English.

Here is the lbset file:
Neje Master 2 Plus - 30W.lbset (5.4 KB)

And here the content of my lbdev file:

    "DeviceList": [
            "DefaultCutList": [
                    "PPI": 0,
                    "angle": 0,
                    "autoBlower": false,
                    "bidir": true,
                    "blowerSpeedOverride": false,
                    "blowerSpeedPercent": 100,
                    "cellsPerInch": 50,
                    "crossHatch": false,
                    "ditherMode": "jarvis",
                    "doOutput": true,
                    "dotMode": false,
                    "dotSpacing": 0,
                    "dotTime": 0,
                    "dpi": 254,
                    "enableCutThroughEnd": false,
                    "enableCutThroughStart": false,
                    "enableLaser1": true,
                    "enableLaser2": false,
                    "enablePPI": false,
                    "endDelay": 0,
                    "floodFill": false,
                    "forceConstantPower": false,
                    "frequency": 20000,
                    "halftoneAngle": 22.5,
                    "hide": false,
                    "index": 1,
                    "interval": 0.10000000149011612,
                    "kerf": 0,
                    "linkDPItoInterval": true,
                    "manualTabs": true,
                    "maxPower": 100,
                    "maxPower2": 20,
                    "minPower": 0,
                    "minPower2": 10,
                    "name": "C01",
                    "numPasses": 1,
                    "overcut": 0,
                    "overrideFrequency": false,
                    "overscan": true,
                    "overscanPercent": 2.5,
                    "perfLen": 0.10000000149011612,
                    "perfSkip": 0.10000000149011612,
                    "perforate": false,
                    "priority": 2,
                    "rampLength": 0,
                    "rampOuter": false,
                    "runBlower": true,
                    "scanOpt": "individual",
                    "skipInnerTabs": false,
                    "speed": 10,
                    "startDelay": 0,
                    "tabCount": -1,
                    "tabCutPower": 0,
                    "tabSize": 0.10000000149011612,
                    "tabSpacing": 0.10000000149011612,
                    "tabsEnabled": false,
                    "tabsUseSpacing": true,
                    "throughPower": 0,
                    "throughPower2": 0,
                    "type": "Image",
                    "zOffset": 0,
                    "zPerPass": 0
            "DefaultToolCutList": [
            "DisplayName": "Neje Master 2 Plus GRBL - 30W",
            "EnableLaser2Offset": false,
            "EnableProcessOffset": false,
            "Height": 440,
            "HomeOnStartup": true,
            "Info": "",
            "Laser2OffsetX": 0,
            "Laser2OffsetY": 0,
            "LastCamera": "",
            "MirrorX": false,
            "MirrorY": false,
            "Name": "GRBL",
            "ProcessOffsetX": 0,
            "ProcessOffsetY": 0,
            "ReverseIntervalCompensation": false,
            "Settings": {
                "AirAssistM7": false,
                "BaudRate": 115200,
                "CommPort": "cu.usbserial-10",
                "EnableBoundsCheck": true,
                "EnableDTR": false,
                "EnableGrblJCommand": true,
                "EnableUserFinish": true,
                "EnableZ": false,
                "EndGCode": "",
                "LaserFire_Enable": false,
                "LastMachineFileExtension": "",
                "LastMachineFilePath": "/Users/oliver/Downloads",
                "NegativeZ": false,
                "OptimizeZ": false,
                "RelativeZOnly": false,
                "S_Scale": 1000,
                "Sim_CornerTolerance": 0.009999999776482582,
                "Sim_FastWhiteScan": true,
                "Sim_FastWhiteScanSpeed": 1500,
                "Sim_GlobalFactor": 1,
                "Sim_MaxAccelX": 800,
                "Sim_MaxAccelY": 800,
                "Sim_MaxSpeedX": 83.30000305175781,
                "Sim_MaxSpeedY": 83.30000305175781,
                "Sim_MinCornerSpeed": 1,
                "Sim_RapidSpeed": 83.30000305175781,
                "Sim_ScanAccelX": 800,
                "Sim_ScanAccelY": 800,
                "Sim_SpeedFactor": 1,
                "SkipWhiteFlag": true,
                "SkipWhiteSpeed": 1500,
                "StartGCode": "",
                "TabPulseWidth": 0.05000000074505806,
                "TransferMode": 0,
                "UseG0ForOverscan": false,
                "UserFinishX": 0,
                "UserFinishY": 440,
                "UserOriginX": 0,
                "UserOriginY": 20,
                "backgroundAdjust": [
            "Type": "Serial",
            "UserCoords": [
                    "IncludeZ": false,
                    "Name": "Middle",
                    "XPos": 122,
                    "YPos": 220,
                    "ZPos": 0
            "Width": 255

Hi, Thanks so much for your help, it’s worked! :grinning:

Now I’m facing a big problem, The power of the laser does nothing, even if i change the percentage to the maximum doesn’t cut anything. I tested with neje’s software and everything is ok . Any idea? I’m using your configs files.

Edit: I’m able to cut, the problem was the speed per min to high. Thanks again.

The setting which is working quite well for me is 95% power, 2mm/s speed and two passes. This cuts my 3mm birch plywood like a charm (haven’t tried much other material so far, though).

I can cut 5mm plywood with this setting: 100/100, in two passes.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.