Network disconnect with 0.14

I’ve searched the forum for similar problems, but come up empty. Here we go.

Red/black clone 60w 500x700 connected to local network via satellite Orbi, hard wired to laser, IP address (no conflict with other devices), Windows 7

All is good with 0.11 but some of those tasty features in 0.14 had me update just yesterday. I had a job running on the machine, which meant the PC was not doing much. Update went fine, LB started up without problem. It said it didn’t find a device, which I figured was okay, since the laser was busy. When the laser is busy, nothing talks to it.

Job done, time for the second phase of the project. Nope. No device found.

I wasn’t going to blame Lightburn at this point, so I powered off the laser, the computer, the home network, brought them all back up again. Still no communications. Even RDWorks didn’t want to find the laser. Curiously, I could ping the IP address and could even nudge it a bit with a web browser and get a response.

Well, what else to check? Nothing.

Downgrade to 0.11 and all communications are back. Even RDWorks is willing to move the head.


Whatever was wrong with my network is not wrong any longer. Update to 0.14 and it all goes to pot once again. This time, the install to 0.14 wasn’t done while the laser was busy, but I don’t think that was an important factor anyway.

Uninstall 0.14 and re-install 0.11 and I’m rolling again.

I think I’ll have to pin 0.14 on the problem, but why would installing 0.14 kill my communications via RDWorks? During this attempt to troubleshoot, I tried the Ruida wireless app on my iPhone. It would indicate it was connected (login successful) but not perform any actions. At one point, the login failed as well.

Now that it’s back on 0.11, the wireless app would login but not move the head. After using the movement controls in the software on the PC to jog the head, the wireless app started working again.

I’d like to use the good stuff of 0.14, but how can I solve this communications problem? What other steps to perform to narrow down/resolve?

I don’t have any intelligent advise for you, but I’ll just toss out there that my 60W red&black is network connected (laser & computer both hard wired to a router) and I’m not having any trouble at all with 0.9.14.

Thanks for the input. I’m hoping to find a trouble shooting approach that will clear whatever it is that’s killing off the connection. Usually, when I compose a problem post, I go through the steps I’ve performed, the results, etc., and figure out the answer. This time, I got to the end of the composition and am still befuddled.

You indicated that the laser is hardwired to router of some sort (Orbi?)
Is your computer also hardwired or is it wireless?

Are you certain there’s no IP conflict between any other devices on the network?

Do this:

  • Install 0.9.14
  • run it
  • go to Help > Enable Debug Logging
  • Right-click the ‘Devices’ button to make it attempt a reconnection
  • Try to send a simple job or do a frame
  • Quit

Post the file called ‘LightBurnLog.txt’ that you find in your Documents folder. I’ll look through it to see if I can see anything odd.

Have you tried disabling anti virus and firewalls you may have enabled? I’v had similar experiences with some other apps after updating them when my firewall sandboxed the new version of an app that I’ve updated.

With the confidence that 0.11 had been running all these months, the network camera system carrying the same IP address made me believe there was no conflict. It’s funny how I could ping the controller and get a response, even when powered down (this morning’s test). It’s been at least six months since the NVR was installed and I have to think that it uses DHCP and stole the IP address from the laser.

I’m no sure why 0.11 would still work when the NVR had the same IP, but now that the laser has a new shiny IP address, all is well with the world, at least with the world of my laser projects.

“All is well” is one of my favorite phrases to hear. :slight_smile:

Will your router let you reserve IP addresses and bind them to a MAC address?

The Orbi interface makes it relatively simple to accomplish the task. My laser is now locked to an IP and I discovered that my DHCP was starting at .2 and has now been pushed to .100. It’s amazing to see how many wireless and wired devices our household contains. The door lock, garage door opener, solar panels, EV charger, umpteen hand-held devices, all taking a bite of the byte stream! Too many unknown devices for me to attack this close to lunch time, though.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.