New HP laptop, new installation, can't connect to the laser

I recently got a new work HP probook, windows 10 installation, 64bit. I don’t have admin rights on the device. The IT at work installed lightburn on my request.
Previous, I used lightburn without a problem with win10 for almost a year now with a dell and a lenovo laptop and the connection with my chinese 60W ruida 6442 controlled laser always worked without a problem. Now, after first installation, I wanted to “find my laser”, but Lightburn couldn’t find it.
I connect to the laser directly via USB. When connected, the display of the laser lights up, and on the laptop, the first time the message appears that the USB-device is being installed. So the usb-connection works, but in lightburn, the laser isn’t found
I tried installing lightburn on my son’s HP pavillion laptop, on which I do have admin rights, but the initial connection with the laser also can’t be established.
I have no idea what’s going wrong, and how I can solve it. I tried installings the laser manually, but no luck there.
I don’t find the solution in the user forum.

You may need to install the driver for Ruida USB, did you select the checkbox to do this on the last page of the LightBurn Install, by chance?


You can re-run the installation program, advancing through until you see this screen, then check that box and select ‘Finish’ to complete the process.

Please try that and let us know how you get on. :slight_smile:

1 Like

Grazie.anche a me è successo questo ed ho risolto seguendo le tue istruzioni.ciao

Thank you. This happened to me too and I solved it following your instructions. Hi

On the laptop of my son, this was indeed the solution! Thank you.
As I don’t have admin rights on my own laptop, I’ll ask IT at work on monday to reinstall and check that box at the end. Hopefully that will do the trick. I’m fairly confident that it will work, given the positive result on the other laptop. Thank you for the tip!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.