New K40 with mini Grbl - Existing files Invert

Hi there, I have switched from a diode laser to a K40. Upgraded to a mini gerbil.
My device is configured for the new K40, grbl-stm, home is top left. My old diode was grbl, and home was bottom left.
When I pull in an existing file, it gets inverted. The graphics and location of the graphics are moved, but the text is showing correctly.
When I create my own file with text or image, everything engraves as expected.
Picture one is what the image should look like, the second is what I get when loaded with device set to my K40.


I know I set the device home location correctly in settings. Homing works fine. Not sure what’s happening or how to resolve to allow me to pull in existing Lightburn files?

I have the same issue with my 60 watt Chinese Laser. All of my old files are inverted and backwards. Even when I straighten them out in lightburn t still burns incorrectly on the laser

Michael, you haven’t found a solution then to the problem? I wonder if there is a config switch you can set for it to ignore home settings/re-orient the picture when loading? Normally it wouldn’t be a problem except that the files have variable power settings, etc., already in there and it would take some time to recreate that.

Does NO ONE have an answer to this issue? Please any answer from Lightburn?

We have an answer, yes. - Device Settings - LightBurn Software Documentation

Origin

This is the origin corner or 0,0 location for your laser. If you have a GCode based system, this is almost always at the front left, regardless of the location of your limit switches.

If you have a DSP laser, like Ruida or Trocen, the origin is usually where the limit switches are placed, and will will be the corner the laser seeks when powered up.

If your laser output is mirrored horizontally or vertically, move the dot to the opposite corner, horizontally or vertically, depending on the direction that the output is mirrored, and that will correct it.

The origin just flips the output. To fix what you see, you can flip your art.

Can’t they change the “Start from:” origin to “User Origin” and set the front left corner with the radio buttons?

This answer isn’t entirely correct with the Mini Gerbil and K40. I did as you suggested, set origin bottom left, it comes out reversed!
Set origin top left, as per the recommended settings from the board manufacturer, flip the image so it is visible, etc., and it seems to be printing ok. That being said, after flipping, I click on any text and edit it that was flipped and it flips back! I have to manually flip it again. Not really that easy!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.