New Member needs Help

Hey Guys , ( at first sorry my English isnt that good i am from Austria ) i really need your Help
I just got a new DIY Chinese Laser with a Arduino CH340 Board. There are two Problems which I can

  1. The Laser drives to the wrong Direction i i press the left Button the Laser drives right , if i press the right Button the Laser drives left. ( i cant change the Slotplace on the Board ) is there mabe a Option on Lightburm where i can Change this ?

  2. Is there an Option where i can but the Laser on very weak Strenght , and then press the Frame Button to see if the Laser is on the Right Position ?

Thank you Guys
Greets from Austria

Welcome. This sounds like you have the Machine Origin set incorrectly in LightBurn. This is the origin or 0,0 location for your laser. If you have a GCode based system, this is almost always at the front left, regardless of the location of your limit switches. What firmware are you using to drive your laser?

You can click the image to expose the ‘Device Settings’ window. Where is this currently set?

Have a look at this post:

Iam sry i dont know which Firmware iam using…
look thats the Position off the Laser in the Moment

What did you set as the device during the setup process?

What is reported in the console window when you connect?

image

i tooked the GRBL …Konsole

Ok, thanks for that. Please re-post a picture of the console window where it shows the grbl version. You can scroll that window back up to the beginning messages of the connection. I also want you to post the entire results after you type $$ into the console and hit Enter (return). This $$ command will list out your current firmware settings.

Have a read here to understand some of the more common setup issues for grbl firmware systems: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md#common-grbl-setups

Thanks for helping me …LAser%20Consele

GRBL%20Bild

Ok, so that isn’t GRBL - it’s “BenBox Laser” which is a custom version that doesn’t support all the commands. And it is from 2015, so if you can find a proper version of GRBL it will work much better. I suggest you can flash your controller to grbl 1.1f or later and then select GRBL in the LightBurn device setup.

Thank you so much Rick :slight_smile:

1 Like