New Setup - TOO FAST

Just setup my JTech Laser and did some test burns…the machine is going WAY TOO fast…i tried adjusting the speed with no resolve. Also, as soon as I hit “Play” it starts my spindle as well. Can anyone help out?

Machine Setup:
CNC4Newbie (48x96)
Demon Controller
VFD Spindle
JTech 7W Laser
Lightburn

*I used to use Easel and still have it

Going way to fast, means the mechanics are moving quicker than expected?

Most of the issue you have will be related to how it’s configured. With your issue, I’d suggest you check and ensure that the ‘units’ the software and laser are using to be the same… Inches/min, inches/sec, mm/min or mm/s…?

These settings are available via the ‘Edit → Device Settings’ for Lightburn for the software…

For the grbl machine, it will have one of it’s registers ‘reporting’ a true/false for ‘inches’. This is in ‘Edit → Machine Settings’.

Generally when you have them setup, they have only a spindle or a laser.

You might want to detail how it’s setup, as we can’t see it and I’ve never used the controller you have.

Did you go through the Lightburn Common Grbl Setup and the Coordinate and Job Origin documentation. They are pretty short, but have lots of setup information.

Good luck

:smile_cat:

I believe I helped this person on Facebook - units were set to inches/sec, so 1.0 would be equivalent to 25.4 mm/sec, or about 1500 mm/min.

It was kind of confusing when he mentioned his ‘spindle’ was spinning up… Not used to one with both a spindle and a laser… Don’t know how exactly how the hardware/software separated the two.

Thanks…

:smile_cat:

He likely has the spindle still connected / powered. On GRBL systems, the laser and rotary spindle use the same PWM signal to enable them.

That’s exactly what confused me… :crazy_face:

Just thought it might have been some new machine I’m not aware of…

:smile_cat:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.