New to Lightburn ( and lasers ) and having g issues with shapes not closed

Sorry to be a pain. I have looked at previous similar topics and tried to follow the advice given, but cant seem to fathom this out.

I purchased some files, and imported to lightburn, some work and some dont. I have used .ai files

the one im having trouble with is saying 6 shapes found, not closed. (When I preview)

![16 hexpancakes|500x500](upload://aBterry hexpancake.lbrn (24.8 KB) BWEH8FKvAN0bvtWIZ3jD6guHj.jpeg)

Looking at other similar reports on here, I have selected the file, selected open shapes, and tried auto join, auto join with tolerances, ungrouped etc, all to no avail.

when I zoom in, the 6 open shapes are showing as marching ants - so, I just dont know what to do next?

If anyone could tell me where I am going wrong, I would really appreciate it, as have spent hours on it and getting nowhere :frowning:

“bunches” of trouble in the design. It looks great on the screen, but it’s a collection of open shapes. Irrespective of the overall problem, you have all six panels set to fill, which will result in a single shape filled, with the hole in the center. Is this your desired result?

Back to the problem: each “leaf” of the design is an open shape. You’ll have to close the shape by creating overlapping lines, or break the overall shape into a few alternating fully closed shapes with alternating duplicated lines to close the remaining segments.

For the image below, I closed one segment by breaking away the appropriate lines and dragging endpoints to for a joint. It’s possible that auto-joining would have worked. Obviously, the outside cut line is included in this image, as I used it as the center point for the rotate feature.
hex rotate 02

Part of my testing was to see if it was practical to create only three segments and close the remaining open gaps. The image below shows this attempt, with the outer hex (and inner hex) turned off.

hex rotate 01

The image below shows the result from performing a 6 unit rotate. The slightly darker lines are the overlaps. They cannot be removed without opening the shapes, negating the fill option. Because the lines are fill boundaries, they aren’t going to cause problems with the laser running twice in one location. The outer and inner hex shapes are set to cut, which will function as expected.

hex rotate 03

adjusted terry hexpancake.lbrn (28.8 KB)

Please note that I created this by starting with a blank page, which means my cut and fill settings have replaced yours.

Thank you so much for your time and trouble, which is greatly appreciated. I will try to follow in my mind exactly what you have done. I am very new to this, and want to develop as deep an understanding as I can. The seller posted me this image of what it would look like once cut… which is the effect I was trying to get.

In the image you show, there is no “fill” used. (and fill requires a closed shape)
Set your blue layer to “line” and set it to a relatively low power so it leaves a nice mark but doesn’t cut. The black layer cuts the shape out and will want to be set to a high enough power to cut through the material. But the key here is that both layers are set to line and not to fill.

EDIT: I’ll also add that the black layer that cuts out the shape should be moved down to be below the blue layer that marks out the hexagons. You want to do the hexagon marking before you cut out the shapes.

1 Like

Hank ( and Fred ) thank you so so much. I feel such a fool!

When I opened the file in Lightburn, one layer was assigned to line , and one to fill.

I then previewed to see it cut… and thats when I got the 6 shapes not closed message.

What you have said makes absolute, and perfect sense now - of course , both layers should be set to line. I wonder why it defaulted on one line and one fill?

However, I cant thank you enough - problem solved and lesson learned! I am so sorry to have been such an idiot!


No fool, no idiot, no worries… just learning new skills is all. We’re all doing it. :slight_smile:


The defaults are just whatever you used last - LightBurn remembers the previous settings used, as a decent number of people work that way. You can change the behavior in the Settings panel, under the File tab, lower right:

Thanks very much Oz - thats very useful to know, and another lesson learned for me.

The more I play with lightburn, the more I am understanding the actions it performs - but the help from this forum, I have to say is amazing…im very grateful

thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.