New user -- no laser

I have an xcarve 1000 x 1000 and I have installed the J tech 7W laser. the problem I have is that the laser will not work. the movement on the x y and Z axis will work for an image that I am trying to engrave but no laser. I have changed the codes for $$30, 31, 32 and 10. the s values match I am unsure what else I can do.

I notice this in the console when I start up do not know what error 9 is.
Waiting for connection…

Waiting for connection…

Grbl 1.1g [’$’ for help]

[MSG:’$H’|’$X’ to unlock]


[MSG:Caution: Unlocked]


one other potential issue the software was unable to detect my system so I added it manually. I would have thought an x carve would have been recognizable

please assist me

Has the laser ever worked with anything else? IE, have you ruled out hardware and wiring at this point and you’re sure it’s just a control software issue?

If you enter the following commands into the console, pressing enter after each one, the laser should fire (very low):

G1 F100 S25

M3 turns on spindle output, G1 is a feedrate move, F100 is the rate, and S25 is spindle speed 25. If your $30 setting is 255, then 25 is 10% of that, so the beam should come on, but at 10% power. Put something under it because it might still burn, and have your glasses on. Type M5 and press enter to turn it back off again.

nothing – no laser.
the laser has never worked I have checked the wiring many times – not sure how to check hardware or control software issue.

I’m not familiar enough with J-Tech hardware to help you on that side. If the commands above don’t give you any output, I would contact J-Tech and see if they can work through the basics of connection and wiring troubleshooting with you.

1 Like

I will and thanks for your time

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.