New user very happy!

I have had a Ruida based China blue for about 5 years now and have been using RDWorks with it the entire time, hating it the entire time. I stumbled across Lightburn a couple days ago watching Youtube and I now have it installed, talking over Ethernet, and working with a camera. It all just works! Wow! Lightburn is so, so much better than RDWorks. Very solid and highly capable. Lots of cool UI aspects that make it easy to use. Also, a couple of the killer features for me:

  1. I am amazed at how well the camera integration works. I had an old 2MP logitech desktop webcam that I attached to the inside of the lid and it works great. Attaining registration of burns onto objects is one of the things that was always a pain with RDWorks- laser pointer, frame, trial and error. Now I easily place the design within less than 1mm of the intended location.

  2. I use Affinity Designer for creating much of my vector work. It does not export the DXF file format which RDWorks wants to see for vector data. I was exporting from Affinity in SVG format and then converting the SVG to DXF (using a cloud service). Now, I export from Affinity in PDF, which Lightburn reads directly. (SVG also works, but there seems to be a scaling issue somewhere along the way). This is a great time saver and I am no longer reliant on the cloud service file format converter.

Anyway, Bravo! This makes the laser so much easier to use. Thanks!

1 Like

Now that you are a convert, go forth and spread the word! :slight_smile:

1 Like

Hi Dave! Welcome to the dark side. (The Light side?)

The Affinity scaling issue with SVGs should be resolved as of version 0.9.10 - they often use pixels as their units, which don’t have a specific size, but if you can set it to use real units, like mm, it should work. I’m going to have to grab a copy of my own and have a go with it. Do you have an SVG example from it that I could try?

Thanks! It looks like the SVG problem is on the Affinity side. When I open the same Affinity created SVG file with Inkscape, it appears the same, incorrect, size as it does in Lightburn. Looking at the SVG file in a text editor, It looks like Affinity might not be respecting the document units setting when exporting SVG. PDFs exported from Affinity work fine.

BTW, I just tried to upload a test SVG file, received an error saying that was not an allowed file type, I changed the extension to .txt (as that was one of the file types that error message said was allowed), but I still got an error saying it was not an allowed extension.

Oops. Just tried to paste XML from SVG and it would not display.

Hi David, you can send the file via email to: developer at lightburnsoftware dot com and include a link to this post and we can take a look.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.