New user with hardware and/or software issues

Hello group, I’m a new laser user and I’m having problems. I posted my issue in a few laser FB groups but haven’t found a solution yet. I went ahead and tried something quite simple today but it isn’t working out for me. See below my original issue and I’ll post pictures of today’s trial and error. Thank you in advance for any help I can get.

Hi everyone, I am new to lasers and Lightburn. Today was my first day experimenting with engraving (wood), and the biggest issue for me right now is my origin keeps moving. I will click the origin button to know where to set my wood, and it will go to the same location maybe 5 times in a row, then suddenly it will choose somewhere else as the origin. Sometimes it has been in the bottom left corner (and that’s what I set it as in the software), but sometimes it will end up somewhere else along the left hand side. I noticed a “set origin” in the software, so I brought the laser down the the bottom left corner and set it, but it still chose to go somewhere else when I clicked go to origin. Any thoughts as to what’s happening? I’m guessing that it has chosen between about 3 different places as origin today during about 15 jobs.

My controller is a cohesion 3D Smoothie.

My software is using absolute coords. and I never changed it between jobs. Both red and green squares are in bottom left of my software canvas. Another thing I thought about and forgot to mention, before using today, I also tried out the “frame” (I watched the first 3 lightburn videos on youtube), I wanted to test it out. It framed perfectly. My image was only approx 4" x 4" (although I’m using mm in the software). But later on when I noticed the origin moving, I tried the frame again, and although my image was now 2" x 2" for the current job I was testing, the frame went around quite a large area. And I’ve only ever had one image on my canvas. One more thing: I wanted to test the limits of my work space. When I saw that “origin” didn’t bring my laser down to the lower left as I was expecting, I used the “set laser position” icon in the left hand side menu (looks like google map location icon), I clicked into the upper right, and my laser wanted to go through the back of the machine. I stopped it quickly.

Today, I tried to burn a round of wood. It didn’t work out… I assume it is related to the other issue, but I am still new at this so I’m not sure.

I tried to post both a before and after picture in my post, but I don’t have that option yet being a new user… so here is the after pic.

So a few more details may be required.
You say you have a Cohesion3D with Smoothieware. Is it a Mini or Laserboard?
What Laser have you added it to?

I suspect that your biggest issue is a simple misunderstanding - Absolute Coords mode ignores the origin, and places work on the machine exactly as you’ve laid it out in the edit area in LightBurn. The other issue you mentioned, where the “Click to move” button bumped into your rails, is a different one. As Chris asked above, what machine do you have the C3D installed in? and, how big is it?

Here is the docs page that describes the different origin settings:

And a video that walks through them a bit more:

This is my laser:

My controller is the Laserboard:

I’m wondering, regardless of my origin, my images shouldn’t have overlapped like that. Here is the picture of my sofware before I sent it to the laser.

It appears you have a larger laser? The LaserBoard comes pre-configured for the K40 which is smaller and the head can move faster. You might be experiencing some lost steps. If you can make a video of the Laser doing the job that would help.

It also looks like your image is not focused - the letters are not that thick in your source image, but the lost steps that Ray mentions is likely the bigger issue for the moment. If you are using the default firmware with the board (Smoothieware) there are values in the config.txt file on the SD card for acceleration and maximum travel speed that you can lower.

Hi Ray, I uploaded the video to YouTube, here is the link. What you are saying about the k40, is that an easy fix? Because this software seems pretty easy to use, I’m so confused about why this is happening. I’ve also attached a picture of the final result because the video cut off at the end.

Yes it’s out of focus a bit because I wanted thicker lines for something else I had tried the other day.

Yes, your motors appear to be skipping steps. You should increase the current and decrease the acceleration values in the board’s config.txt file.

There is another forum for Cohesion3D, and I would suggest posting there for a more thorough explanation of what to do and how.

1 Like

The “grinding sound” you hear is your steppers missing steps. Visually, it looks like the machine is moving faster than you’ve asked it to as well. It also appears that the cut is physically larger than it should be - The full job appears to be about 2" across in LightBurn, but it looked like it was bigger than that on the laser - is that correct?

These things are pretty easy to adjust, but it will take a bit of trial and error. Things you will likely need to change if your machine isn’t a standard K40:

  • Motor current for each axis
  • Acceleration
  • Step lengths (or steps per mm) for each axis
  • Maximum travel distance for each axis
  • default travel rate for G0 moves

All of these things are in the config.txt file on the SD card.

  • alpha_steps_per_mm is for the X axis
  • beta_steps_per_mm is the Y axis
  • acceleration is the acceleration in mm/sec^2 (try a low number like 1000, then increase it)
  • default_seek_rate is the speed (in mm/minute) of travel for non-cutting moves
  • alpha_current and beta_current are the current settings for the stepper drivers

Start by running a very slow square of 100 x 100 mm at low power, maybe 25mm/sec. Measure how big the machine cuts it, and use the ratio to adjust the step per mm numbers. For example, if you tell it to cut a 100mm square, but it cuts a 150mm square, your steps per mm number is too high by 150/100.

Once you have the step lengths, then start slowly increasing the other speeds until things start skipping again, then back off by about 20% from there.

It also looks like you’re still out of focus - Look up “laser ramp test” on Google to figure out the optimal focus distance for your setup.

1 Like

When I suggested posting to the C3D forum, I meant and not the Facebook group :slight_smile:

1 Like

Ok thanks Ray, I’ll go there.