NEWBIE and I am falling down a rabbit hole quick!

I am going to try and put this is simple and organized as I can.

SYSTEM:
1- Ortur laser 2 MAX with a LU 1-4 laser Class IV laser
2- Using a Macbook Pro, (Have not tried to install firmware update)
3- Build in GRBL via lightburn console is as follows

$I
[AUTHOR: RenShen]
[BUILD: Ortur Laser v1.2]
[DATE:22:23:00 - Feb  6 2020]
[VER:1.1f.20170801:]
[OPT:VZD,35,254]
Target buffer size found

4- Bed size is 19.5: x 18" or 495 x 457 mm

CURRENT ISSUES
1- Home, (on start up and also hitting home button) takes the laser to the far right front and grinds it into the corner. (Hard shutdown to stop it)

SOLUTIONS TRIED VIA FORUM AND GRBL CONFIGURATION DETAILS
1- Tried changing $130=150.000 $131=160.000, to $130=400.000, $131=400.000. I have read that this only works with Soft limits on Homing enabled. But I tried!
2- After much frustration did a reset of the GRBL code using $RST=* and all G54-59 coordinates were set back to 0
3- Also have tried several time to install lightburn on a PC laptop, install goes perfectly but then I try to open the program and get this error message saying that entry point K32GetModuleInformation could not be located in the dynamic link library KERNEL32.dll

Anyway I am in a bad way here guys and could use some help. I managed to get this thing to do an engraving, which resulted in the image or text in this case to print in revers. I then reversed the text or mirrored it and it worked, but I know this is not how the machine should work.

Appreciate some help here before go plumb crazy!

Hi, have you set your ‘origin’ (the position of your machines ‘home’) in device settings(top of page, spanner and screwdriver).

All issues resolved with the 140 1.1h update. Had to run the .exe. file from a PC but the process went perfectly and my only word of advice is this when running the firmware update.

1- Download the .zip file from ortur/tech/latest-firmware
2- unzip the folder, then unpack the files onto your desktop
3- On your Ortur lazer hold the power button down for 3 seconds, then while holding it, press the reset button and then let both go. The light will flash and the file folder should pop a window up.
4- Copy, DO NOT DRAG the file which is a .bin file, the only one in there, should be 48KB into your window that opened for your lazer. Close all windows, power the laser off, open lightburn and turn on your laser. All should be perfect.
5- To check the system took the update, in the console type $RST=* and you should see the version changed to 140 and 1.1.h

1 Like