Newbie - axis backwards

When using Lightburn it appears as if the axis are backwards. I don’t have this issue with freeware.
When I move from the home position to the center of the work area, lightburn thinks I am way outside the box.

Here is a video so you can see what I mean.

This looks like you do not have the ‘Machine Origin’ set correctly in LightBurn. Have a read through this and let us know the results.

Thanks for the response but I followed that3 or 4 times now. AT my work we call that RTM, read the manual. ha. But seriously maybe something in here will help

$0=10 $1=25 $2=0 $3=6 $4=0 $5=0 $6=0 $10=0 $11=0.010 $12=0.002 $13=0 $20=1 $21=1 $22=1 $23=1 $24=25.000 $25=500.000 $26=250 $27=1.000 $30=1000 $31=0 $32=1 $100=401.500 $101=400.165 $102=401.500 $110=500.000 $111=500.000 $112=500.000 $120=10.000 $121=10.000 $122=10.000 $130=300.000 $131=180.000 $132=40.000

Click the ‘Spanner/Gears’ icon near the top-center of the LightBurn screen to expose the ‘Device Settings’ page and post a screenshot here. Do you have the ‘Origin’ set to the lower-left dot as shown below?

What happens when you do this?

I get the same result.

image
This indicates that LightBurn thinks the laser head is off the workspace to the low-left side. Are you saying that if you move the head to the front-left of the frame, then power up OR power up then enter G92 X0 Y0 into the console, you jog movement is still going in the incorrect direction?

What is the exact version of firmware you are running?

Yes, When I move the head to the front-left then power up and then enter G92 X0 Y0 movement is still going in the incorrect direction.
Grbl 1.1h
LightBurn 0.9.14

Do I need to reverse X and Y somehow?

This is what is strange, after I power up and enter the G92, look where the laser is…odd

I spy an Alarm state being reported, so that is worth knowing.

ALARM:1 - Hard limit triggered. Machine position is likely lost due to sudden and immediate halt. Re-homing is highly recommended.

You do not need to do both,

What happens when you just place the head to the front-left, then power the system on? What is reported in the console when you first connect?

In the console, type ? and hit enter. Then type $# and press enter. Copy and paste the output here.

When I place the head to the front left and power up the 3018 I get ALARM:1
image

$#

[G54:31.212,30.107,0.461]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G28:-32.868,-30.152,14.624]

[G30:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

ok

?

<Idle|WPos:-31.212,-30.107,-0.461|FS:0,0|WCO:31.212,30.107,0.461>

ok

You say movement is opposite to what you expect. You have $3 set to 6 (2 + 4) meaning that X is not reversed, but Y and Z are. Is it only the X axis that’s reversed? If so, try setting $3=7, to reverse the X axis as well.

I tried to watch the video but your logo keeps appearing over all the stuff I’m interested in looking at, and I can’t dismiss it:

ALARM:1 is hard limit triggered, so either you’re moving the head to the point where it’s pressing a limit switch, OR you have limits and homing enabled, but don’t actually have switches, which would cause major problems. $20=1 in your settings, meaning soft limits are enabled - the machine will try to prevent you from traveling out of bounds. $21=1, which means hard limits are enabled, so if you hit a limit switch it will trigger an alarm. I could not tell from the video if you have limit switches.


I do have limit switches

You have a workspace offset programmed into G54 / WCO. In the console, type G10 L2 P1 X0 Y0 to clear it.

That did the trick on the direction, looks like it is fixed. but now I get an ALARM 2 even though it is not up against a limit switch. I think I’ll turn off the limit switches. To do that set both $20 and $21 = 0?

Boom- fixed. Thank you so much and sorry for being so much trouble.
In the future how can I keep from programming a workspace offset? I assume I did it without knowing what I was doing.
In the future I want to use this laser to cut holes in a plastic enclosure and need repeatability so I think I will use absolute coords, find a spot to mark as the starting point then go.

It’s easy enough to check if there’s an offset by typing ? and looking at the ‘WCO’ values - if they’re not zero, you have an offset. The G54 entry when you type $# shows it too. LightBurn will never change that, but it’s common for CNC software to do it - That’s what ‘setting your zero’ is doing - setting an offset between the actual zero point of the machine and the work piece. LightBurn does this by just remembering that point (when you click ‘Set Origin’) and simply moving there when starting a job. Much simpler, no offsets required, doesn’t affect homing, jogging, or machine limits.