Newbie help please

HI folks. I recently installed a laser on my X Carve and finally got around to installing Lightburn today. I have a current version of GRBL(1.1g) and Lightburn (0.9.07).

If I use the jog buttons for X and Y my machine moves correctly. If I try to “move to position” in ANY increment, the machine goes flying to the right rear corner of the machine and crashes into the frame rails.

I have told the software the working size of my machine. If I jog the machine and click on “Get Position”, it looks like the values are going into the negative.

Thanks in advance.


Controllers dedicated to CNC use are set up so all coordinates in the work area are negative, for some reason I’ve never understood. You need to offset the machine origin to make them positive, described step-by-step here:

Thanks Oz. I’ll give that a whirl.

Will those settings only affect my Lightburn work area, or Easel too?

They’ll affect both. Typically we have people set a macro for using the laser, and another for going back to CNC, as there are a couple settings to change:

Use laser:
$32=1 (laser mode)
$10=0 (report positions in user workspace)
G10 L2 P1 X-(offset) Y-(offset)

Use CNC:
$32=0 (spindle mode)
$10=1 (report positions in absolute machine space)
G10 L2 P1 X0 Y0 (remove workspace offset)

OYE. I only bought these particular products because my research showed they were seamless. First things first. Let me see if that’s what’s actually going on.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.