Newbie here with lots of questions

So Im brand new to the laser world.
Just installed the JTech 7 watt on my X Carve with the X controller.
Downloaded Lightburn and Im pretty much completely lost.

  1. Why can I not see the full screen.
  2. I have everything plugged in and turned on but the software says its still waiting for a connection

Are we not allowed to post screen shots here?
I’m sure it would help in understanding my situation.

As a new user, you should be able to paste or upload one image per post.

  1. What do you mean you can’t see the full screen? Is the window not filling your monitor? You can pan around with the space bar or middle mouse button, if that’s what you mean. Zoom with the mouse wheel.

  2. Did you add your device through the devices menu? You can reset the connection by right clicking the Devices button too, btw.

Thank you for the response.
I followed the directions (I think) when I downloaded the software
Sorry I just now saw the upload button.
Its been a very frustrating couple of days.
This is my screen shot.

Yeah, being super new, I’d recommend following the suggestion and set your machine up using the M3 device. Your other option would be to install a newer firmware version on your controller, such as 1.1f (You’re running Grbl 1.0c). Someone here might be able to point you in that direction, but I don’t personally have any experience in that area.

If you are using a very small display (like 1024 x 768 or lower) you’ll need to rearrange the windows along the right side to stack/tab them all on top of each other, or you can hide your Windows bar along the bottom to give the software a bit more room.

Having said that, it does appear that your controller is being found and connecting - are you having other issues?

1 Like

Sorry it took so long to get back.
I’ve been so frustrated that I decided to get on the John Deere and clean up the yard today here in sunny (70° Ohio)
I always use my laptop 17"
never had a problem before with any other software
also I notice that i should be able to undock tabs and then put them back when the “area” turn blue.
Doesn’t work for me.

‘Laptop 17’ does not give any indication of the resolution of your display. The resolution is the important part, not the display size.

The docking works, but requires that there is enough space for the chosen window to ‘land’. If you try to triple-stack them, for example, if your display is too short it wouldn’t allow this. You should be able to undock all windows then stack them all on top of each other by dragging them all off the right side, then one-by one dragging them back onto the right. For windows after the first one, drag them to the center of the first window and it should change color.

resolution is 1366 x 768
Apparently the best i can do

Why is this the only response I get when connecting

Do you have another COM port available? The first image you posted showed COM13 as the port that did connect. You may have another device plugged into your computer that looks like it could be a laser, and LightBurn will connect to the first one it finds, or the last one you chose.

Very strainge.
I have been using picsender for several years now and it is always plugged into the same port.
com 3
when I try to connect lightburn, the only options that I get is com 4 or com 5

so I shut lightburn down and restarted.
Now it gives me the option of com 3
when I click it I now get this message.
Looks like its still not connecting

‘ok’ means it’s connected, I believe. You should switch to the M3 device though, instead of the normal GRBL one. Or update your firmware to 1.1f.

How do I do that?
These are my divice options.

Switching to the M3 device is easy. Same as you did already, just choosing the different device.

Updating firmware is beyond the scope of this post probably, and certainly beyond my knowledge. I could probably stumble through the process, but a quick google search should help you out.

Ok I found it.
switched to M3 and nothing changed

If it says ‘ok’, then it’s connected I believe. You can verify by sending the console a $$ command. It should spit out a list of variables.

This is what I get when I enter $$

Grbl 1.0c ? How delightfully vintage.

So what should it be?
What do I need to do to change it?
Keep in mind that I still need to be able top use Picsender