Newbie Overlap problem

I’ve come over from RDworks, and imported coreldraw file of overlapping shapes. On RDworks, I could delete overlap. On Lightburn, it won’t delete overlap if it is grouped, but even after ungrouping, there is a lot of overlap left. I have hairlined, and checked optimization delete overlap. The lines are definitely overlapping, and only manual deleting after breaking everything apart works. If I try to open the coreldraw dxf file in rdworks, it adds flat lines above and below the circles, which makes me think there is something hidden that I can’t find.
Airplane launcher 8 ALL PARTS sheet.lbrn2 (184.3 KB)

Seems these 4 cutouts have some level of overlapping segments. LightBurn delete duplicates feature only works for true overlapping duplicate shapes.

If you’re working in CorelDraw you could probably avoid these issues entirely by exporting as SVG or AI format instead of DXF.

Well spotted. I missed that. RDworks allows you to specify how much is overlap. Two converging lines, will be completely overlapped as soon as they are 0.1mm apart. If you run a simulation on Lightburn, you will see there is a lot more overlap that is not removed. If you open in RDworks, you will find lots of lines appear near the circles. Any advise to improve on the delete overlap 100% of the time?
Thanks for the suggestion of SVG. I will try that, but don’t think it will delete very close lines.

So if you have 4 adjacent lines that are 0.1 mm apart, how many lines would you have left?

I didn’t see any real overlap. Are you not using “Remove overlap lines” in Cut optimization settings? If not and your goal is to avoid multiple passes with the laser that’s the easiest way.

What I did notice is that there are odd travel paths due to the way the lines are joined which I assume is due to the DXF being exported as small segments and getting joined automatically in LightBurn in a weird way. This is why I was saying using SVG or AI as an intermediate format would work better. You wouldn’t be losing object information.

I didn’t see any issues near any of the circles. Can you take a screenshot of RDworks?

To me the main key in this is to make sure you have a clean source file. So no duplicate objects in the original design. Then not introducing any potential issues by using DXF where shapes need to get reinterpreted. To me if you’ve brought duplicates into LB then it’s already too late.

I will try SVG tonight, and let you know. I appreciate your help, and are very grateful.
I usually snap shapes together on coreldraw, then use RDworks to remove overlap (or very close overlap). I haven’t tried multiple lines spaced 0.1mm. The remove overlap setting is selected in cut optimization. Did you watch a simulation of it and notice some lines get cut twice?
I hope to add a screenshot tonight.

I walked through the simulation but did not notice any twice cut lines. But it’s possible I went too quickly.

I don’t know why RDworks uses DXF files so well. Your SVG file advice has solved the problem. Thank you.

CorelDraw, SVG, and LightBurn all use Beziers to draw curves. Better to retain that information through the conversion process rather than breaking up the curves into small line segments like pretty much all DXF exports do. This makes conversion more difficult, less accurate, and more error prone. Not ideal if a better alternative is available.

Of course this isn’t always possible when coming from CAD type programs that typically do not use Beziers but rather NURBS or Splines.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.