Niether Z-axis or airassist runs after GRBL


I run a K40 with Cohesion3D Mini with GRBL 1.1 and ofc LightBurn.

I swapped from Smoothieboard to GRBL with great improvment of speed and reliability.
Suffer tho from z-axis and airassist doesnt run anymore.

Now I manually move the bed which will be hard after upgrade to 700x400 and manually plug or unplug the airassist.

Any clue where to start?

For Z you would likely need to adjust the steps per mm, speed, and accel for the Z axis in the controller (Edit > Machine Settings).

For air assist, that one I’m not sure of. I know that it does work on both firmware, but the output pin might be different. C3D should be able to tell you that.

But the z-axis doesnt move at all?

Okey, i talk in that forum instead regarding airassist… issue with so many company :slight_smile:

You might only have a 2 axis build of the GRBL firmware. Z and A axis might need a different build, but C3D should have the 4-axis version on their website for download. If the steps per mm are really small, the motor would move, but the Z table would barely move at all. You might also need to set more current for the Z axis driver.

No I run the
Which should be a 4-axis with open drain for Z (I got a external driver).

I can see the Z-axis shaft and it doesnt move so if I request 20mm movement or 100mm.

Posted in C3D-forum now, see if they can figure something out

(If they find any solution will I i post it here for searching).

When running one of my grbl-lpc firmware builds with external drivers, you must disconnect the stepper driver enable line for the driver to work. External drivers require a active high enable to work.

M8 air assist is Pin output P2.6 on the mini. M7 is not enabled in any of the grbl firmware builds.

It is explained in the above Wordpress post.

Oh… the right man for the question I assume!
The wiring is done by this guide

Could you help me to figure what to rewiring?

To make the external driver work with grbl-lpc, just disconnect the ENA+ wire on the driver side. Wrap some electrical tape on the end to keep the wire from shorting something else. This should fix your Z table issue.

Tested that with no progress. The stepper is powered because it locks itself.
Did exactly like
Disconnected the ENA+ (but fixed 5v for DIR+ and PUL+)

Tested in both lightburn and a basic grbl-controller (which could handle Y-X with ease

If the rotor is locked then the driver is “enabled”.

This is likely a wiring issue with the step and direction. Please verify everything still works using smoothie firmware.

I just checked the grbl-lpc firmware with open drain Z using a external TB6600 stepper driver. Wired using the Cohesion3D document. The enable line was left unconnected. It works fine here. Make sure you download the correct firmware version from my link above.

You may need to invert the Z step pulse to work with your driver.

If you are still having issues, I suggest you keep using smoothie since I can’t give much hardware support. The firmware works on my end.

So… I tested to upload Smoothie again and it shows here

Then uploaded

Which should be a open drain for Z-axis?

Results after upload is this (only removed ENA+ but contained 5v to the other).

Can u possible send a photo of your wiring while using TB6600? And Switches are set to SW1 OFF, SW2 OFF, SW3, ON (SW4-6 regarding of stepper current)

I rather run your GRBL with adjusting Z-bed with external button than using Smoothie :slight_smile:

Did you invert the step pulse for Z?

Yes with $2=4
No success

Try $2=0 instead

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.