Noobie needs help understanding origins

Hello all. I’m totally new to lightburn, liking what I see.
I’m using xcarve with jtech 2.8w. I have been through the setup videos and got lightburn working with my machine, however I can’t figure out why my machine keeps crashing into limits. Manually moving works correctly however. when Create something to etch it goes off in the direction of either my 0,0 and crashes.
I know its me not understanding something basic, but really need with this.
Thanks and sorry for noobie questions

The origin settings in LightBurn are explained well here:

You might also need to set up a machine origin offset to get your system into ‘Positive Workspace’, and that’s explained here:

thank you for responding. I have read the documentation you sent. Slowly wrapping my head around how lightburn works. I was able to complete a test job using current position. still trying to understand why after homing my machine tries to crash in to limits. I’ll keep at it because I believe lightburn is a valuable tool.
is it possible to use gcode created in vcarve? would make things easier for me .
thanks again,
appreciate your help

If your machine homes to the rear-right, and is normally used as a CNC, you most likely work in negative space, and have to set a workpiece origin to use the CNC. In LightBurn, that workpiece origin is the front-left of the machine, regardless of the mode you’re using.

If you type $$ into the console and make note of the values for $130 and $131, those are your travel extents (the size of the working area for your machine).

Enter this command, but substituting in the numbers shown for ($130) and ($131):

G10 L2 P1 X-($130) Y-($131)

So, for example, if I was using a Shapeoko XXL, which has a workspace size of about 817mm, I’d use:

G10 L2 P1 X-817 Y-817

That applies a negative offset that shifts the origin from the rear-right to the front-left. If you do that, and also make sure the $10 setting is $10=0 (reporting in workspace coordinates, not machine coordinates) everything should work as expected.

To clear that offset when you’re done, use G10 L2 P1 X0 Y0

It’s simplest to put these into a pair of macros you can use, called “Use Laser” and “Use CNC”.

For laser:

G10 L2 P1 X-xxx Y-yyy

For CNC:

G10 L2 P1 X0 Y0

It is possible to use GCode created in VCarve, but then there wouldn’t be much point in having LightBurn. LightBurn won’t import the other gcode, but it will send it to the machine for you if you click the ‘Run GCode’ button. near the start button.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.