Not able to connect to laser

New laser - RM Laser RM960. Ruida controller. Lightburn trial. Windows 10. Won’t connect with Ethernet or USB. Auto or manual. Lan indicator on Ruida says not connected. Cables firmly in side of controller. IPaddress established. Third set of digits is 1. Does it matter which space the 1 is in? Middle, center or right. Flashing red light on light 14 which I think is for water temp not being up yet thus morning. Solid Red light on light 15. First laser for me.I have followed the procedure for ethernet explained in the forum.
Need some help. Thanks.

well if the controller already says it is not connected your cable may be faulty/wrong

Could be I suppose but seems unlikely that both the USB and ethernet would be faulty. They are both new and came with the machine.

Water temp is within safe range now and the red lights are still both on.

Can you ping the IP address you have assigned to the laser from the PC

you could try to connect your cables directly into the controller and not in the machine

Will not ping. Says IP unreachable.

I’m just about to try that. Thanks.

What is the IP address of your laser?
What is the IP address of your computer?
Are you going through a router or switch, or is it a direct connection from computer to laser?

1 Like

IP computer
IO Laser
I just tried plugging USB directly into the side of the controller. I’m able to run other devices from this USB port. I have those two red lights as I described above. Have tried shutting laser machine off and then on again. Have tried rebooting computer. Windows 10,

This needs to be addressed. You should be able to ping the laser if connected and configured correctly on your network, so please show us a picture of your current ‘IP config+’ information displayed on the HMI of your controller.

Here is an example of what we’d like to review:


Hmm. Your IP’s seem reasonable.

What software came with the machine? RDWorks I assume? Does it connect with that?
Have you tried a different cable?
Just for fun, try a different (lower) IP address on the laser, like
I dunno. I’ve got my Ruida hooked via ethernet, but I connect through a router. It always just works…

Edit to add: Just looked at Ricks post. I forgot to ask about the gateway.

Could you also include part 3 of Hanks questions. Everyone at this point are just trying to help with the Ethernet connection so USB is not relevant

OK, I fooled with this another couple of hours. I hooked up with ethernet, changed the IP address so the last digit area was 15 and the lan showed on. I went through the manual system for ethernet but still no connection even though the panel said ‘lan on’
so i switched to USB and tried the auto recognition - nothing and the panel now switched to ‘lan off’. I rechecked the IP and it had reverted back to having the last digit field as 100. I changed it back to 15 and rehooked through ethernet and the lan shows ‘lan on’, however, I am not able to connect I noticed thtat when the ‘lan on’ shows that i have three of the red lights on at the controller.
I have no idea what to try next. I did down load RD works yesterday and tried to connect with that but was not able to.
I’ve emailed the folks at RM Laser but haven’t heard from them. guess they are a half world away.

All my connections have been directly from the computer to the controller.

Thank you for these observations, yet the important part, I’d like you to explain a bit more.

What did you try to determine that you are, “not able to connect”? Did you try to ping the laser again? What result did you get? I asked if you could show a picture of your control panel showing the IP config+ screen. After you change the IP, did you save the setting? What Gateway did you set?

Please answer these important questions. We are trying to diagnose the issue, but are not there to “see” what you can. We need your help to do so. :slight_smile:

Rick I sent the photo by email at around 3PM Central since some of these messages showed up on my email. I’ll try to attach the photo on this site in the morning. I did not try to ping after the LAN on indication. Long day trying to figure this out and really frustrating but I’ll try the photo and the ping again in the morning. I don’t have internet in my shop so everytime I message or check for them I have t disconnect and come back to my office. Since I’m only on trial status I cannot connect to this forum on my desktop. Search for Ruida support turns up nothing.

It says at the top of the device area that the device is disconnected. I did save the settings. Made no changes to the gateway. It is as is shown in the photo.

Ah, I did not look for an email. Please provide when you can.

Not following you on this. There is no connection between our trial software limiting access to this forum whatsoever. They are completely different things and no nothing of each other, so help me understand the issue.

If you need more time to trial, please send an email with your trial ID to support at lightburnsoftware dot com and we can extend it for you.

forget about the lights on the controller, for the usb …did you try to make a file on a usb stick and see if your controller can read the usb at all? Did you install the driver (lightburn asks you when you install)