Not able to set Machine settings in Lightburn

I have no settings in my lightburn program. I open it and it is blank. I followed the You tube instructions on installing limit switches but it is half in chinese and half in english. Can anyone help me with my mess? I have a Sculpfun S9. Also my console says waiting for connection. When I click the home button it says busy and 100% Do I have to Have GRBL installed first?

You should need to install the driver first.
Can you see witch port is in use with Sculpfun board?

1 Like

Absolutely, lots of clever folks here. It’s almost a compulsion to ‘fix the thing’.

These most likely stem from the notion that you aren’t connected and communicating with the Laser engraver with LightBurn yet. The Sculpfun S9 is a fairly robust device. There are a couple of unfamiliar steps on the path but this won’t delay you for very long.

LaserGRBL points toward the Serial Driver that allows your computer to communicate with the processor in the controller. LaserGRBL can leave the communications settings in a strange state when it closes and I’ve seen this disrupt communications. It’s nice to have but it can make it necessary to shut off power to the Sculpfun (& unplug the USB cable) to get it to forget the odd state.

This might look a little intimidating but this is the chip manufacturer’s website.

Click the wide blue button with the cloud and down-arrow and that’ll give you the most recent and stable version of the driver. After it’s done with the download, run it and it will enable your computer talk to the controller. We may have to fiddle with a couple of settings after this but this feels like the biggest unfamiliar step in the process.

LaserGRBL offers a pretty reasonable place to start with Communications settings.
https://lasergrbl.com/usage/arduino-connection/

With the Driver installed, launch LightBurn, connect the usb cable last.

Then, if these windows aren’t open, please open the Console window and the Laser window. If you haven’t seen this yet, click Window in the top row and roll down the list and make sure there’s a check mark beside Console and Laser.

The complete process and a better firmware can be found here: Limit Switches - Diode Laser Wiki

As the others stated, first, set up your laser correctly, this will help a lot :slight_smile: Setting up the software - Diode Laser Wiki

I have Lightburn installed and evertime I hit frame the laser printer doesn’t move . The console says <idle|MPos:0.0000,0.0000.0.0000|FS:0.0,0|Ov:100,100,100100>
ok
Start stream
Stream conpleted

I keep getting a G-code locked out during alarm or jog on my console when I exit and reenter lightburn

error 9 message

Well I spent time with lahobby guy and he went over all the settings and trials to get the machine to work properly. We got thwe machine to home and do everything but frame. When I hit the frame button it moves to the top right of thee machine and statrs jumping going to the limit. He said it is a software problem and that I should ask for help’

Can you share the file you are trying to frame. That could be settings a few settings.
Always i have a problem like that i had something out of place.

OK
Drill Sergeant Identification Badge - Copy.dxf (889.2 KB)

It looks like you have selected “start from” - Absolute Coord.
Try one or both of this:
Set “start from” to current position (for exemple) with the laser head in the middle of the table. Then hit “Frame” it should frame only the badge.
Or
Move the shape (badge) close to the Job Origin (green square on bottom left corner, and hit “Frame” it should move a little the Start position and frame the badge.

This is a DXF file, it maybe something different of lb files but that should not be a problem, just a correct setting. :wink:

I did as you said and nothing happened. The laser says ready and the console says OK

I get a red Alarm:2
Gode motion target exceeds machine travel. Machine position safety retained. Alarm maybe unlocked. (Right-Click the “device” button to reset the connection) On or near line 2:
steams complete in 0:00
[MSG:reset to continue}
at the bottom line it says OK in black

Pay attention to working size area:


then hit $$ in console window and focus on $130s parameters.
They should never be above the value of your working area.

Check if you are working on the same units mm or inches.

Maybe Gcode in the dxf file has coordinates too long for your working area. I had a quick view and it seems it’s all ok, but i am not sure.

I reset everything as you instructed and the machine still will not frame

I did get it to frame when using current position. I can’t frame anything in any other start positions and i’m limited to only 200 X 200

Ok,… I am not an expert but I am just telling you what I do if I were you…
So,… how did you get this? “i’m limited to only 200 X 200”? Did you see it somewhere?

What does your Device Settings look like? Specifically the working size, any offset, as well as the origin (and compare that with the Job Origin in the Laser panel)

This screen:

My thought was that maybe you have your laser origin set to bottom left, but Job origin to center or another side, thus losing a part of the board

Also, and this might be a silly question, but does it happen in other projects? If you start a new project, make a small circle, will it frame?

1 Like

This is the DXF file that OP share opened on my seat.

At this seat i can’t make any test but I pointed the “start from” and “job origin” to you can see too.
These settings seem to me likely to give the kind of problem the OP is having.

You are in absolute coords, you can’t change the origin when using absolute coords.

On my pc, the file opens with current position selected as job origin