Not returning to same origin/current position when framing a tumbler

I am using Piburn grip (set to 12,800 steps), an Omtech AF2028-80, and Lightburn 1.4.00.

When I manually move the laser using arrow to verify circumference it works perfect. For example, I set circumference of the tumbler I’m working on to 236mm. I draw a mark on the tumbler and set laser pointer to that mark. I click the up arrow in lightburn (‘move’ tab) while having distance set to 236 and it makes one perfect rotation stopping exactly on the mark it started from, so I know circumference and steps are set correctly.

However, when I frame the design, it does not return to the original starting position for some reason. This is a chuck rotary and I’m certain it’s not slipping in any way. I have the speeds and acceleration turned down for framing and rotation in the y axis. I’m using current position like always. Each time I frame, it stops about 3-4mm short of the original start position. Any idea why that might be happening?

Get a felt pen and put a mark on each sprocket between the motor and the chuck (inclusive). Ideally color in half the shaft and part of the sprocket then rerun your framing operation.

Hopefully it’s just a loose set-screw.

The tumbler is a bit like a flywheel. It will resist acceleration and deceleration. Rotating one full turn to prove the axis calibration may not show the same behavior as the 4 frame moves and the Traverse move at the beginning.

If the motion isn’t at the chuck, and if it’s not in the drive system, it’s motor slip and it’s probably best to lower the accelerations.

I would assume your hardware is OK as is your steps/rotation from your description. Meaning your procedure or setup is incorrect. Is this your first shot at the rotary?


A little more detail on how you set these up…

What are the start from and job origin entries?

If your start from is user origin, you need to press the origin button on the Ruida machine console…

I’d suggest not using current position… although it should work.

I always use user origin and press the origin key when it’s setup… after that you can just stick in another mug… I’ve had a couple people change over to user origin and press the button have had success.

Do you swap out the Y axes for your rotary?

If you run out of options, I don’t know how this setting effects the rotary… in Edit → Machine settings, right above vendor settings is a return setting… or something like that…

It pretty much has to be something in your procedure… if it’s not forgetting to push origin… :wink:

:smile_cat:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.