Odd Lines not in design

I get straight lines that are not in the design. It just randomly engraves in lines all over the place!

Can you show a picture, and give a bit more information, like what kind of computer you’re using, how you’re connected to the laser, and which version of LightBurn you’re using?

Have you used the laser in the past, or is it brand new?

I am having the exact same issue. Just randomly started this week. This is in addition to lines shifting all over the place. It’s a Line & Fill, on a Mac laptop, Have done this project before , actually re doing some of the exact files I’ve done before and have never had this issue.

If you’re using a Mac connected to Ruida over USB, that’s the issue. Read here:

Downloaded and ran it once, looks good. Now when I try to frame from lightburn, it only goes to the starting point and stops, rather than framing. I am fairly new at this software/laser, coming from a Glowforge, but have found that running everything right from Lightburn rather than my controller works best - till these issues - should I be doing more from my controller? I’m not yet versed enough to say most of what happens to me isn’t user error but this thread has been a TREMENDOUS help today!!!

As far as I can tell, all of this is because of the Mac and the driver. Everything is supposed to work exactly as you think it should, and on a PC it does, using exactly the same code. If you connect your Mac to the laser with an Ethernet cable, it works exactly as intended.

I’m not quite sure what your recommendation is here. I do not have an ethernet port on my Mac. I do have a PC that I can switch to and have downloaded lightburn to that but am getting nothing when I’m trying to use the setup wizard so I have to get to the bottom of that. This is the file I just ran and am getting the horizontal lines and thrown off letters again. I’ve done this project before and didn’t have any of this happen so I don’t really get why my Mac is suddenly the problem.

This photo was run on the Mac

Apple sells a USB to Ethernet adapter for $30. That is (and always has been) our recommendation for Mac users. That said, we’re also working on an alternative that will allow direct use of WIFI, with no dropouts or communication issues, but it’s still in test.

Have you updated MacOS since running the job previously? Or LightBurn? Our newer code is more efficient, so in the version linked above I’m actually throttling it back intentionally to keep from “choking” the USB connection. The driver on the Mac is not allowing me to enable the feature required to let the connection self-throttle, which is the only true way to do it reliably.

You may need to install the Windows driver at the end of the LightBurn installation. Installing Lightburn - LightBurn Software Documentation

image

If you have never installed LightBurn before, you might need to check the ‘Install FTDI driver’ button - this is mostly used by DSP controllers, like Ruida and TopWisdom, and it only needs to be done once. If you update the software later, you do not need to repeat this step.

So…I walked away, came back today to try all of this and am being asked for a license key and when I put it in, am being told I’ve already used up my licenses. Any advice there? Pulling my hair out…

Moved everything over to my PC, just tried to run again and am still getting horizontal lines randomly in design.

The lines are still happening and happen in different places every time. Then on another one it seems to be working and falls apart on the last few lines.


Any further feedback on this issue? I have ordered a new Apple Cable USB to Ethernet and will try it again but it has been so inconsistent in the issue I’m wondering if anything else has been determined.

Have you tried this same job, using the exact same settings from RDWorks to see if you are getting the same results? That would help to determine if this is a software issue.