Odd problem with user origin and coordinates

This is almost certainly a user config problem:

JTech laser mounted to XCarve. I have a fixture mounted roughly in the centre of the machine bed that holds round workpieces. They aren’t coasters… but let’s call them coasters to keep things simple.

So what I want is the work origin in the centre of the fixture.

Machine is set up with home left front (positive coordinates) per XCarve default. Homing machine correctly executes homing cycle. Jogging works as expected.

Jog laser over to fixture and use “Laser Fire” to align laser with the centre of the fixture. Select “set user origin”. My expectation is that I have now set “work zero” the same way one does in a usual CNC context.

Down in the lower right part of the screen, set user origin to centre. Draw a circle around it, set cutting parameters. Set origin to “current position”, press Run, laser cuts a circle in the correct spot.

Set origin back to “user origin”, press Run, machine rapids hard left and forward.

Re-home machine. Jog back to the fixture centre, press “set user origin”, then go to “get position” from the move tab, and instead of it being “0, 0” as expected, it is something like “-10, -8”.

Which is deeply weird, because the machine definition definitely is positive coordinates.

My expectation is that I should be able to power up, home, jog to a location, set user origin, power off, power on, home, then select “go to zero” and the machine will move the the zero set earlier - because that’s what happens in a CNC context.

What am I missing?

As you are aware, there are a couple of different ways to tell LightBurn how to cut the project within the work area of your machine. These are defined using our Coordinates and Job Origin controls. This is where we provide the details of how each of these settings work and how best to utilize these features. https://lightburnsoftware.github.io/NewDocs/CoordinatesOrigin.html

This is also worth reviewing, helping to walk through a simple project, from start to completion. The last section, “Positioning the Job on the Laser” provides a good review with expected results that might assist you as well. https://lightburnsoftware.github.io/NewDocs/SimpleProject.html

Have you run the macro that LightBurn sets up to move your machine origin to front/left and set the proper reporting mode? ($10=0) That setting tells the controller to report positions relative to the zero you set, not relative to the zero from homing.