Offset 'failure'

I want to get an offset to a profile which has a very sharp corner. The picture below shows the profile and the offset shown. The rounded corner is what I want.


However, when I use the OK button I get the following - the rounded corner has disappeared and been replaced by a straight line.
image
I get the same ‘error’ when using the other Corner Styles. I have varied the offset distance but the problem remains.
Is this a bug or is there a setting somewhere that allows me to get what I want?

Probably neither. :grin:

In weird cases like this, the geometry typically has something invisibly wrong with it, perhaps duplicated curves, overlapping points, non-closed paths, or even more bizarre situations.

The offset should work the way you expect and does in a quick testcase I just tried that probably doesn’t replicate your geometry:

Upload the failing *.lbrn2 file so we can take a look at it.

If the shape “crosses over” itself at the point, that will mean the offsetter can’t figure out if it’s inside or outside the shape, and that will confuse it.

Thank you. I will look more at the geometry. As you may have guessed the sharp corner is supposed to be formed by two arcs meeting tangentially. I have uploaded the file - it will be interesting to hear what you find.
yy outline uploaded.lbrn2 (10.9 KB)

It should not cross over itself but I will have a look. I think they are supposed to meet tangentially.

If you take the “short” handle and move it inward (left) even a TINY amount, it’ll guarantee that the inside/outside solve is correct, and gives accurate results.

This is at maximum zoom, so you can see what I mean:
image

If they’re perfectly in-line with each other, the system can’t determine inside / outside for the geometry at the endpoint, and that’s why you get the truncated bevel.

3 Likes

Thank you. I have had a look at other Lightburn files that have, supposedly, the same shape in them (these were imported from similar CAD produced geometry via svg files). The offset worked as wanted. So I can only guess that for some reason the geometry of the ‘failing’ case was very slightly changed so that it did not work. Your TINY edit corrected the problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.