Omtech Not connecting via USB

Hello, I am trying to run my new OMTech 60 watt laser via my Linux laptop but I am unable to connect to the machine via USB. I am running Ubuntu.

3 things to check for:

  1. Did you follow the installation instructions? Specifically the portion about group membership?
    Installation & Setup - LightBurn Software Documentation
sudo adduser $USER dialout && sudo adduser $USER tty

If you haven’t done this you will need to relogin after executing this to reflect the group permissions.
2. Can you confirm that a serial device is created for the laser? Run this in a terminal.

ls /dev/*USB*

There should be a port dedicated to the laser. If you don’t see one there then something isn’t working correctly.
3. In that case check your system messages. Can you unplug and replug the laser and then run this in a Terminal:

dmesg | tail -n 30

Return the output here.

I did what you said. This is my first time using Linux. When I was messing with the settings I manually made a profile for the cutter but I would like to delete it or be prompted again to add the cutter. How do I go about doing that? Ill need to do that before I can check to see if your fix worked.

In Laser window push Devices button. There you can delete or edit your devices. You can also attempt to do a “Find my laser” there. This assumes you have permissions to access the serial port.

Keep in mind that not all devices are always detected and manual creation isn’t necessarily a problem assuming settings are correct.

That worked! It detects it now. Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.