Opt Laser working on X-Controller


(Benjamin Sheets) #1

So, I purchased an Opt Laser and they have recommended Lightburn software as the best option to operate their laser with an X-Carve. I have read the forum and it is very unclear on the solution to fix the negative workspace issue (I believe this is my issue).

My machine is 30" X 60" and it is set up to home in the front left corner. Every time I have tried to run the “G0 X0 Y0” command it runs to the back right corner hitting the limits. I have entered “G10 L2 P1 X-15 Y-30” and “G10 L2 P1 X-30 Y-60” in the command line and it has no changing effect on the performance of the machine. What can I do to make this work?


(Oz) #2

Check your $10 setting - it should be 0 for LightBurn, as that affects how the machine reports it’s position. You might also need to do the offset in mm (worth checking, though I’m honestly not sure).

The offset is described in detail here: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md#common-grbl-setups


(system) closed #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.