Optimize Z Offset

Hi, I hope everyone is staying healthy and safe! I have a job with a FILL layer, LINE layer for scoring with a Z offset and a final LINE layer for cut. I’m using a Sunlight Laser machine with a Ruida controller at a local makerspace. I turn on ‘Enable Z Axis’ and ‘Relative Z moves only’. I can’t use the machine now so I can’t try this but I wanted to ask and get ready.

1- When the job starts, the FILL layer fills the texts.
2- I have a LINE layer with a Z offset. This LINE layer has a lot of scorings. The bed moves correctly, but it moves back and forth on every line of the layer.
3- The bed moves back to it’s initial Z height and does the cut with the other LINE layer.

I didn’t have time to try it but if I enable ‘Optimize Z moves’ will the machine do all the scoring on layer 2 without adjusting the bed height for every line on the same layer? Anything I should be careful about?


1 Like

Optimize Z Moves tells the software to only move the Z height when necessary. The default behavior is to always retract, in case you’re doing something like engraving inside items with height.

Think of engraving the bottoms of jewelry boxes, for example - If you were doing that, you would want the head to retract between moves so as not to hit the sides of the boxes. Since we can’t know what you’re intending, the default is conservative.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.